c

Membre habitué

Inscrit le :15/10/2016
Dernière activité :08/01/2020 à 22:29
Version d'Excel :1RQI982
Messages
83
Votes
0
Fichiers
0
Téléchargements
0

Sujets créés par ced91300

DateForumSujetExtrait du message
08/01/2020 à 20:58Excel - VBACombiner si/ou avec samedi dimanche Jours FerriésJe n'arrive pas à imbriquer les fonction si/ou avec samedi dimanche et JF (les date se trouve en D) =SI(OU(JOURSEM(D$8;2)=6;JOURSEM(D$8;2)=7);"0";"8") → fonctionne m'affiche bien la valeur "0" si samedi ou dimanche = SI(OU(JOURSEM(C$8;2)=6;JOURSEM(C$8;2)=7;(C$8)=Ferrié));"0";"8") → Quand je veux raj...
12/10/2019 à 14:07Excel - VBACopier jusqu'a la derniere ligne remplie d'un classeur ferméJ'ai un code vba qui copie la feuille d'un classeur fermé, actuellement il fonctionne très bien mais avec un nombre défini de ligne. J'aimerai si possible à la place qu'il fasse la même chose mais automatiquement jusqu'à la dernière ligne remplie, car le nombre de ligne à copier peut être variable....
13/01/2019 à 11:34Excel - VBA Fonction decaler et indirectJe n'arrive pas à finir ma formule =NB.SI(INDIRECT(A10&"!A5:J500");$D$9) J'ai les 2 indirects qui font bien le job, mais je n'arrive à ce que le nombre de valeurs comptées soit ceux en colonne "J" en apport à ces 2 indirect, je pense que c'est peut-être avec la fonction décaler, mais je n'arrive pas...
12/05/2018 à 13:33Excel - VBAAdaptation d'un VBAJe cherche à adapter ce code VBA ci dessous à ma situation(Mettre les entêtes ListBox via 1 Fram). Ma base de données elle comporte des éléments de A à K, mais je ne trouve pas comment le faire (à chaque fois j'ai un code erreur) celui-ci est pour une base de A à I Merci de votre aide Cordialement...
04/05/2018 à 23:09Excel - VBARemplir automatiquement un textbox en fonction de 2 autresJ'ai un userform avec plusieurs textbox je souhaiterai que se remplisse automatiquement un des textbox textbox 1 je rentre la date ex : 04/05/2018 textbox 2 je rentre la durée de validité en années ex : 10 textbox 3 je souhaiterai qu'automatiquement soit affiché dedans le résultat soit pour l'exempl...
12/11/2017 à 13:50Excel - VBA Chemin classeur et concatener celluleJ'ai un fichier Excel que je remplis en fonction des document, je cherche à mettre un lien vers le dossier correspondant de chaque document. je suis parti de l'adresse du fichier excel : =(GAUCHE(CELLULE("nomfichier";A1);TROUVE("[";CELLULE("nomfichier";A1))-2)) (cela me donne l'adresse du fichie...
13/09/2017 à 10:32Excel - VBAPlanning equipe suivant l'heurePour un planning j'aurai besoin d'afficher en B l'équipe correspondante en fonction de l'heure dans A1 mais je ne trouve pas la formule EQUIPE 1 = matin EQUIPE 2 = apres midi EQUIPE 3 = nuit B = type d'équipe suivant l'heure en A exemple : en A1 format = 13/09/2017 11:00 je voudrais voir afficher en...
11/09/2017 à 14:32Excel - VBA Combobox resultat en fonction d'autreEst-il possible d'alimenter automatiquement en direct une combobox en fonction de 2 autres pour une date d'échéance Par exemple : Dans combobox14 je met le nombre de mois dans une annuelle "12" = au nombre de mois dans combobox15 je met la date disons le 11/09/2017 égale à la date d'entretien Et je...
09/09/2017 à 15:44Excel - VBA Textbox en cascade pour trier une bas plus listboxJ'ai une base qui est rempli et modifier par un userfom (là tout vas bien) j'ai besoin de reprendre cette même base via un autre userform pour y trier celle-ci en cascade par 3 critères de recherche via 3combobox correspondant aux colonnes de recherche puis le résultat dans la listbox j'ai trouvé un...
08/09/2017 à 21:52Excel - VBA Copier totalité d'une listbox dans un feuilleJe recherche un code vba pour copier (via bouton) tout le contenu de ma listbox vers la feuille nommé "résultat" en postions A19 . ( nombre de ligne texbox variable suivant filtre via 3 combobox) , Merci Cordialement...
03/09/2017 à 20:20Excel - VBAForder date dans texbox ou laisser videJ'ai crée un format obligatoire dans certaines de mes Texbox suivant la methode ci dessous, par contre certaines d'entre elles resterons vide, mais au moment de valider il refuse "date incorrecte" je suppose que je dois rajouter la formulation "ou vide" mais je ne sais pas comment l'imbriquer dedans...
02/09/2017 à 12:09Excel - VBA CommandButton actif sous conditionJe suis à la recherche du vba pour rendre actif un bouton sous condition : En fait je souhaiterais rendre actif mon CommandButton1 que si les texbox1, et texbox2, et texbox3 sont remplis, Merci de votre aide Cordialement...
25/08/2017 à 21:29Excel - VBA ListBox et cellule vide dans un triLa macro ci dessous fonctionne bien elle recherche les dates dépassées en colonne "I", mais j'aurai besoin d'ajouter que : si dans cette colonne ("I") des cellules sont vide ne pas les prendre en compte. (actuellement elle me les prend en compte dans l'alimentation de la listebox.) (de A jusqu'à j '...
17/08/2017 à 17:48Excel - VBA Formule prenant en compte le nom d'un ongletJ'ai 2 classeurs j'aurais besoin que dans le 2eme classeur celui m'affiche une partie du contenu du premier Le 1er classeur (toto) J'ai les noms d'ongles année la formule actuelle='[$toto.xls]2017'!$C$6:$M$17 va bien me chercher les éléments sous forme d'image dans le fichier toto.xls (2017...
09/01/2017 à 10:46Excel - VBABva et bouton imprimer liste boxJ'ai un bouton pour imprimer une ListeBox , je souhaiterai rajouter un message de confirmation d'impression et qu'il soit imprimé que certaine certaines colonnes, mais je ne sais pas comment rajouter tout ca sur la macro suivante: Merci de votre aide. cordialement . Private Sub CommandButton1_Click(...
04/11/2016 à 17:35Excel - VBA MFC suivant le mois de la dateJ'ai sur un classeur avec toutes les date du 01 janvier au 31 décembre sur une seule colonne colonne A 01/01/17 02/01/17 03/01/17 et ainsi de suite..... (jusqu'au 31/12/2017 je n'ai pas trouver comment faire une Mise en forme conditionnelle pour qu'un mois sur 2 soit ombragé (pour une lecture plus f...
02/11/2016 à 10:06Excel - VBA Bloquer le classeur si les macros ne sont pas activésJ'ai un classeur Excel planning d'une équipe avec macro mdp utilisateur afin qu'ils n'accèdent qu'a leur propre service mon problème c'est que si il n'active pas les macros, il peuvent arrivé à voir tout le classeur. ils peuvent utiliser n'importe quel pc de la boite, et le classeur se trouve dans u...
20/10/2016 à 10:32Excel - VBASommeprod et indirectJ'ai cette formule qui me recherche le nombre de valeurs de façon indirect =+SI(ESTVIDE(C26);"";SOMMEPROD((INDIRECT("'" &C27 &"'!A5:M370")=C28)*(INDIRECT("'" &C27 &"'!A5:A370")>=E24)*(INDIRECT("'" &C27 &"'!A5:A370")<=G24)*(INDIRECT("'" &C27 &"'!A2:M2")=tab!C26))) C26 "nom" (format déroulant) C...
18/10/2016 à 21:30Excel - VBA NB.SI avec fonction indirect dans une autre feuilleAvec cette formule : =NB.SI(O5:O370;"*"&R25&"*") (cherche le nombre fois qu'il se répète le mot inscrit dans R25) je cherche à ajouter un choix de feuille ou il doit rechercher les elements (plage identique pour toutes les feuilles) dans A1 j'ai mis un menu déroulant avec les noms de mes 20 feuilles...
15/10/2016 à 23:52Excel - VBA Soucis dans une formule SI OU ETJ'ai un petit soucis dans la formule suivante =SI(OU(ET(JOURSEM(A5;2)>5;$N$4=0);ESTNUM(EQUIV(A5;feries;0));$N$4=3);"RH";"") Premiere condition tout vas bien elle fait le job SI(OU(ET(JOURSEM(A5;2)>5;$N$4=0);ESTNUM(EQUIV(A5;feries;0)); par contre la deuxième partie $N$4=D5);"RH";"") m'inclus ES...