Formule somme.si.ens

bonjour,

je suis sur Excel 2016.

J'ai joint un tableau : je n'arrive pas à faire fonctionner cette formule.

Quelqu'un peut-il me dire ce qui cloche dans ma formule ?

D'avance merci.

PS : je ne veux pas passer par un tableau croisé dynamique.

Bonjour Jean Paul,

Si ta SOMME.SI.ENS ne fonctionne pas, c'est parceque le critère "msm", "test" et "zorro" sont à l'horizontale sur ton tableau de donnée.

Il faudrait que tu utilise une formule MATRICIELLE ou que tu te rapproche de la formule SOMMEPROD

Restant à ta dispo

bonjour

c'est souvant le binz avec cette formule .... faisons classique et plus explicite

5jean-paul.xlsx (8.92 Ko)

cordialement

Merci,

Mais ça reste encore pas mal "flou" !

Serait-ce abuser de me faire un modèle de formule sur mon tableau ?

Bonjour,

dommage cette réticence sur les TCD, tu ne sais pas ce que tu perds De toute façon, ta table de données n'est pas adaptée en l'état.

Pour rester sur la même fonction :

=SOMME.SI.ENS(B$2:B$16;$A$2:$A$16;$A22)

à tirer vers le bas et vers la droite.

Si l'insertion de lignes ne te gène pas tu as aussi l'outil 'Données / Plan / Sous.total' :

2018 07 02 15 28 18

eric

re

avec des fleches , tu noteras la position des $$ pour incrementation "cool"

et ça change du vert vintage tulipe avec un titre pontifical

3jean-paul-2.xlsx (11.74 Ko)

cordialement

re bonjour,

je n'ai rien contre les tableaux croisés dynamique,

je dois préparer des budget par type d'opération.

A priori avec la formule sommeprod, je devrait y arriver, alors qu'est ce qui cloque dans ma formule C7 ?

Cf pièce jointe

re

et comme ça ???

4jean-paul3.xlsx (29.26 Ko)

cordialement

avec le SOMME.SI.ENS() aussi. Tu n'as pas testé ma proposition ?

c'est souvant le binz avec cette formule .... faisons classique et plus explicite

tout à fait ! j'aime le SOMMEPROD

Bonjour,

Tulip_' merci pour ce fichier jeanpaul 3.

Je remarque que WS LYON est en dur et ne fait pas appel à une variable, dans ce cas la case F1.

Le but était le suivant : j'ai 15 tableau du même type que WS LYON, je voulais donc dupliquer une feuille et ne changer qu'une seule variable pour que ce tableau ce mette à jour, et non pas modifier l'ensemble des formules (même avec un remplacer ou autre copier coller).

Il n'y a donc pas d'autre possibilités ?

Sincèrement.

bonjour

bon du coup je ne vois plus que cela (choix dans liste)

3jean-paul-6.xlsx (29.37 Ko)

cordialement

ok

je crée mes 15 feuilles et je change dans le menu déroulant !

super.

Dernière question : le menu déroulant pointe sur quoi ?

C'est au cas où une opération prévue change, que je puisse changer l'intitulé.

Merci.

le menu pointe sur la première ligne (celle en couleur) regarde dans gestionnaire de noms : liste

Rechercher des sujets similaires à "formule somme ens"