Récupérer valeur en fonction de deux critères Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
M
MickaelC
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 18 octobre 2013
Version d'Excel : 2003

Message par MickaelC » 18 octobre 2013, 22:46

Bonjour,

Je cherche la solution à mon problème depuis un bon moment et je commence tout doucement à m'avouer vaincu car je n'arrive pas à savoir quelle fonction je suis censé utiliser.

J'ai un premier onglet A appelé "client"
Colonne A : nom du client
Colonne E : Tarif mot
Colonne F : tarif ligne
Colonne G : tarif horaire
Colonne H : tarif mini

J'ai un deuxième onglet B "Novembre" où j'enregistre les demandes de traduction au fur et à mesure.
Colonne E : Nom du client
Colonne F : unité (soit "mot", "ligne", "horaire" ou "mini")
Dans la colonne H (tarif unitaire) de ce même onglet, j'aimerais pouvoir récupérer les tarifs renseignés dans l'onglet "client" en fonction du nom du client et du type d'unité choisie.

Exemple :
Dans l'onglet A, j'ai un client qui s'appelle Dupont qui me paie 30 l'heure.

Dans l'onglet B, lorsque je renseigne le nom de client "Dupont" (dans Col E) et que j'indique "Horaire" (dans Col F), j'aimerais qu'Excel me récupère le tarif correspondant dans l'onglet A.

J'espère avoir été clair...

Si quelqu'un pouvait me mettre sur la piste, ce serait très sympa !

Cordialement,
Mickaël
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'703
Appréciations reçues : 243
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 18 octobre 2013, 23:06

bonsoir
voici une autoroute SOMMEPROD
Fonctionnement
=SOMMEPROD(( plage des noms= le nom)*(plagedes cas=le cas)*(plage des tarifs))
attention :les plages doivent etre de la meme dimension (nb de ligne)
attention aussi a l'ortographe et a tout ce qui parait pareil mais qui ne l'est pas
cordialement
c'est en cherchant qu'on trouve
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'156
Appréciations reçues : 376
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 18 octobre 2013, 23:07

bonsoir,

une proposition de formule
à mettre en H2 de la feuille novembre ...
=RECHERCHEV(E2;client!$A1:$E100;2+ENT(TROUVE(F2;"mot    ligne  horairemini   ")/7);0)

edit bonsoir tulipe
Modifié en dernier par h2so4 le 18 octobre 2013, 23:17, modifié 2 fois.
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'703
Appréciations reçues : 243
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 18 octobre 2013, 23:12

bonsoir h2so4
sans fichier ,ta reponse est ,disons.......... sulfureuse : ai je l'air caustique ? :lol:
cordialement
c'est en cherchant qu'on trouve
M
MickaelC
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 18 octobre 2013
Version d'Excel : 2003

Message par MickaelC » 18 octobre 2013, 23:18

Bonsoir,

Merci pour vos deux réponses. Malheureusement, je n'arrive pas à implémenter vos propositions...

Je mets un fichier en pièce jointe pour que ce soit plus clair :)

La formule recherchée va dans la cellule H2 de l'onglet "novembre".


Mickaël
Test.xls
(16 Kio) Téléchargé 27 fois
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'156
Appréciations reçues : 376
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 18 octobre 2013, 23:27

bonsoir,

formule proposée adaptée à ton fichier et mise en H2

=RECHERCHEV(E2;Clients!A1:H12;5+ENT(TROUVE(MAJUSCULE(F2);"MOT    LIGNE  HORAIREMINI   ")/7);0)
Test (5).xls
(19.5 Kio) Téléchargé 31 fois
M
MickaelC
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 18 octobre 2013
Version d'Excel : 2003

Message par MickaelC » 18 octobre 2013, 23:33

h2so4 a écrit :bonsoir,

formule proposée adaptée à ton fichier et mise en H2

=RECHERCHEV(E2;Clients!A1:H12;5+ENT(TROUVE(MAJUSCULE(F2);"MOT    LIGNE  HORAIREMINI   ")/7);0)
Ça marche parfaitement :)

C'est frustrant de voir que tu y as passé 3 minutes alors que je cherche depuis...trop longtemps :s

Maintenant je vais essayer de comprendre la formule pour pouvoir la réutiliser...

Merci beaucoup encore et bonne soirée !
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'156
Appréciations reçues : 376
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 18 octobre 2013, 23:47

MickaelC a écrit :
=RECHERCHEV(E2;Clients!A1:H12;5+ENT(TROUVE(MAJUSCULE(F2);"MOT    LIGNE  HORAIREMINI   ")/7);0)

Maintenant je vais essayer de comprendre la formule pour pouvoir la réutiliser...
voici les explications

les paramètres de fonction rechercheV sont
(mot recherché,
plage contenant les infos qui nous intéressent (le mot sera recherché dans la première colonne,
la colonne de la plage à afficher si le mot est trouvvé,
paramètres indiquant comment la recherche doit se faiire)

donc on recherche E2 dans la colonne A1:A12 de la plage A1:H12 et on affiche le contenu trouvé dans la colonne donnée par
5+ENT(TROUVE(MAJUSCULE(F2);"MOT LIGNE HORAIREMINI ")/7)

on recherche la première position du mot F2 (mis en majuscule) dans la chaine de caractères "MOT LIGNE HORAIREMINI ", mot sera en position 1, ligne en 8, horaire en 15, et mini en 22. en prenant la partie entière de la division par 7, je ramène la réponse à 0,1,2,3 auquel j'ajoute pour avoir le numéro de la colonne qui m'intéresse donc 5,6,7 ou 8 (ce qui correspond à E,F,G ou H) soit les colonnes qui contiennent le tarif Mot, Ligne, Horaire ou Mini dans la plage A:H
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'703
Appréciations reçues : 243
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 19 octobre 2013, 00:51

re
un essai autrement
mikaelC.xls
(16.5 Kio) Téléchargé 28 fois
cordialement
c'est en cherchant qu'on trouve
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'703
Appréciations reçues : 243
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 19 octobre 2013, 01:10

re
ou alors avec SOMMEPROD
mikaelC.xls
(17 Kio) Téléchargé 26 fois
cordialement
c'est en cherchant qu'on trouve
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message