Trouver le minimum des valeurs avec des colonnes décalés

Bonjour,

Exemple : on a 4 pièces pour faire une fenêtre qui s'appelle : X

Les pièces s’appellent : a, b, c, d...

Je voudrais trouver une équation qui détermine le nombre des fenêtre qui sont prêtes pour l'assemblage, car une fois, les 4 pièces sont fabriquées, on commence l'assemblage, en gros si a=1, b=2, c=1, d=4, ===> la quantité de fenêtre faites = 1 car on a peut assembler qu'une seule fenêtre.

Mais si on a : a=2, b=2, c=3, d=4, ===> la quantité de fenêtre faites = 2 ..... En gros ça va prendre le minimum toujours, mais le problème, c'est que des fois j'ai plus que 4 pièces donc sur Excel, j'ai plusieurs colonnes et entre les colonnes de la quantité des pièces il y a des autres valeurs qui correspondent à autre chose, et il y a un décalage de deux colonnes entre chaque quantité de pièces. Donc si j'utilise la fonction MIN, il me faudra un décalage, mais j'arrive pas à trouver comment je peux le faire sur ce genre d'équation.

J'ai mis un tableau Excel si vous voulez faire des essais.

11test.xlsx (11.62 Ko)

Quelqu'un peut m'aider SVP!!!!!

Merci d'avance.

Bonsoir Rayanchou92, le forum,

Un essai.....

en D6: =SI(ET($F6<>"";$I6<>"";$L6<>"";$O6<>"");MIN($F6;$I6;$L6;$O6);"")

Cordialement

si tu as des pièces supplémentaires tu peux modifier la formule précédente:=SI(ET($F6<>"";$I6<>"";$L6<>"";$O6<>"");MIN($F6;$I6;$L6;$O6);"") pour

=SI(ET($F6<>"";$I6<>"";$L6<>"";$O6<>"";$Q6<>"");MIN($F6;$I6;$L6;$O6;$Q6);"")

bonsoir

une contribution avec une matricielle (Ctrl maj Entrée)

=MIN(SI(E5:P5=$F$5;E6:P6))

ou alors

MIN(SI(MOD(COLONNE(F5:P5)*2;3)=0;F6:P6;""))

pour ta piece jointe

cordialement

Bonjour,

Merci les gars pour votre aide, sauf que vos formules s'appliquent pour 4 ou 5 pièces, dans ce cas, c'est facile de modifier l'équation, mais si j'ai 40 pièces ou plus dans cette fenêtre, je fais comment ?

Au fait, je voudrais que la fonction commence à comparer toutes les valeurs de la quantité faite à partir de la cellule F6, en gros elle part de la cellule F6, elle saute deux colonnes puis elle compare F6 avec I6, puis elle saute deux colonnes.... jusqu'à une fin que je détermine, comme par exemple : AQ6.

Merci bcp

Cdlt

bonjour

du qui saute en prevoyant large

=MIN(SI(MOD(COLONNE(F5:GG5)*2;3)=0;F6:GG6;""))

cordialement

Bonjour,

Merci tulipe_4 mais ça marche pas car elle la fonction compare toutes les valeurs sur cette ligne elle saute pas les deux colonnes

Cordialement,

bonjour

comment ça ????

22rayanchou.xlsx (274.35 Ko)

cordialement

Regarde la P.J tu vas comprendre

Cordialement,

5rayanchou.xlsx (275.14 Ko)

re

valide avec les 3 touches Ctrl Maj Entrée et tu verras

cordialement

Merci

ça marché

Cdlt

Rechercher des sujets similaires à "trouver minimum valeurs colonnes decales"