Extraction de données

Bonjour,

je vous sollicite pour un petit soucis d'extraction de norme matière a partir d'un ERP.

Je m'explique je récupère des normes matière mais une seule partie m'intéresse (la norme principale sans le code épaisseur).

En effet, les normes de bases sont constitué de 3 ou 4 lettres suivi d'une série de 4 chiffres et les chiffres après que je souhaite effacer.

Exemple 1 : ABS5064A040 je souhaiterai avoir dans une autre colonne ABS5064

Exemple 2 : ASNA3526-0350 je souhaiterai avoir dans une autre colonne ASNA3526

Merci d'avance pour vos suggestions.

10classeur1.xlsx (8.72 Ko)

Bonsoir,

Une proposition de formule, à tester (teste si le 4ème caractère est numérique ou pas) :

=SI(ESTERREUR(CNUM(STXT(A2;4;1))); GAUCHE(A2;8);GAUCHE(A2;7))

Bonne soirée

Bouben

Bonsoir,

avec une formule en matricielle

13classeur1-3.xlsx (9.45 Ko)

Bonsoir,

Voici ce que je te propose si le forma du texte ne change pas.

8a-tester.xlsx (8.93 Ko)

bonjour

la matricielle du mardi

8grbzh.xlsx (9.47 Ko)

cordialement

La solution retenue est la formule en matricielle classeur1(3)

Merci pour cette solution qui marche à merveille, j'ai tester les autres mais il y avait quelques incohérence sur certaines references.

Je retiens donc la solution du classeur1(3).

Merci à tous pour votre aide et vos recherche.

Grbzh.

Rechercher des sujets similaires à "extraction donnees"