Excel, Nb.si dans plusieurs feuilles

Bonjour,

Je vais simplifier le problème que j'ai pour une meilleure compréhension.

Disons que j'ai 2 feuilles dans un classeur avec chacune "Rouge" en A1 et "Bleu" en A2 par exemple et je veux en Feuil3 compter le nombre de "Rouge" présents dans les 2 feuilles dans la plage A1:A2.

La formule nb.si(Feuil1:Feuil2!A1:A2;"Rouge") ne marche pas.

Merci d'avance.

Bonjour

alors sans fichier et à froid, je partirai pour :

=NB.SI(Feuil3!A1:A16;"rouge")+NB.SI(Feuil4!A1:A16;"rouge")

Plage des feuilles de A1 à A16 par exemple.

Cdlt

CORDIA5

Ah mais il n'y a pas moyen de cumuler toutes les feuilles ? Parce que si j'ai 30 feuilles ça ne va pas.

Je suis pas chez moi je ne peux pas mettre le fichier Excel.

Bonjour,

Pour répondre simplement également, ce type de référence Microsoft : Feuil1:Feuilx!B3, se nomme une référence 3D.

Il n'y à que quelques fonctions qui acceptent ces références 3D, en voici la liste (Source : Microsoft 04.11.2016)

MOYENNE

AVERAGEA

NB

NBVAL

MOYENNE.HARMONIQUE

KURTOSIS

GRANDE.VALEUR

MAX

MAXA

MEDIANE

MIN

MINA

CENTILE

CENTILE.EXCLURE

CENTILE.INCLURE

RANG.POURCENTAGE

RANG.POURCENTAGE.EXCLURE

RANG.POURCENTAGE.INCLURE

QUARTILE

QUARTILE.EXCLURE

QUARTILE.INCLURE

PRODUIT

RANG

EQUATION.RANG

MOYENNE.RANG

COEFFICIENT.ASYMETRIE

PETITE.VALEUR

ECARTYPE.STANDARD

ECARTYPE.PEARSON

STDEVA

STDEVPA

MOYENNE.REDUITE

SOMME

VAR.S

VAR.P

VARA

VARPA

Bien à vous

Jp

Donc pour mon problème je ne peux utiliser aucune formule de la liste ?

Bonjour,

Pour 4 feuilles nommées Feuil1,Feuil2,..

=SOMMEPROD(NB.SI(INDIRECT("Feuil"&LIGNE(1:4)&"!A1");"X"))

Si les noms des onglets sont dans un champ nommé nf

=SOMMEPROD(NB.SI(INDIRECT("'"&nf&"'!A1");"X"))

Ceuzin

Ça ne fonctionne pas. Pourtant tout semble bon... :/

Bonjour à tous,

ou alors il faudra passer par VBA ...

P.

à défaut , sur base de la formule de "ceuzin" , un exemple

389remylml-xlp.xlsx (9.73 Ko)

bonjour

une contribution par l'exemple

640remyml.xlsx (8.80 Ko)

cordialement

Bonjour

En m'inspirant de l'excellent site xlerateur, j'ai bidouillé une macro déjà existante pour répondre à votre demande, enfin je l'espère.

Cdlt

Bonjour,

J'espère que quelqu'un me répondra malgré la date des échanges de message.

Voila, je cherche à calculer un quartile à partir de plusieurs plages de données dans plusieurs feuilles de calcul de mon fichier excel. Pour cela j'utilise =QUARTILE(('2019'!AL2:AL654;'2018'!AL2:AL490;'2017'!AL2:AL430;'2016'!AL2:AL310;'2015'!AL2:AL439;'2014'!AL2:AL340;'2013'!AL2:AL508;'2012'!AL2:AL337;'2011'!AL2:AL385;'2010'!AL2:AL357);1) et le résultat est : #VALEUR!

Je n'arrive pas de trouver d'autres solutions pour calculer ce quartile. Pourriez-vous m'aider s'il vous plait et si possible sans VBA car je ne maîtrise pas cet outil...

Merci par avance

Rechercher des sujets similaires à "feuilles"