Comment mettre deux cellules composées d'heure et date en tranche horaire

bonjour a tous,

je viens solliciter votre aide sur une tache qui me boque en Excel depuis une semaine. alors, j'aimerais savoir comment mettre en tranche horaire de 03 heure deux cellules contenant la date et l'heure chacune c'est à dire: 07H-10H; 10H13H ainsi de suite... dans un TCD pour avoir le cumul traité par tranche horaire.

le but est d'avoir le nombre de camions traité par tranche horaire entre l'arrivée et le départ.

merci d'avance de votre aide.

6kpi-dit.xlsx (9.83 Ko)

exemple:

DEPART QUAIARRIVE DEPOTDEBUT DECOMPTEDEPART DEPOTSEJOUR DU CAMION
03/01/2022 11:5103/01/2022 12:1503/01/2022 12:1503/01/2022 16:274
03/01/2022 13:0203/01/2022 13:4803/01/2022 13:4803/01/2022 19:005
03/01/2022 14:4003/01/2022 16:4603/01/2022 16:4503/01/2022 22:306
03/01/2022 13:5503/01/2022 15:5203/01/2022 15:5203/01/2022 18:002

Bonjour soar,

Bienvenue sur Excel-Pratique.com !

Ci-joint une proposition de formule pour déterminer la tranche horaire. Je te laisse le soin de terminer ! ;)

12kpi-dit.xlsx (12.57 Ko)

bonsoir

à tester

=HEURE(PLAFOND(E3;0,05)-D3)

cordialement

bonsoir a tous,

merci à Tulip_4 pour la formule, elle m'est utile par contre j'ai des chiffres négatif qui ressortent dans certaines cellules…

merci à AntoineDL s'est top ; c'est le fond de ma pensé. Est ce que tu peux enlever la date dans l'élaboration de la formule des tranches horaires! quand on établit le TCD les tranches horaires se multiplient en fonction des dates.

merci d'avance.

Bonjour soar,

Il te suffit de supprimer la partie "date" de la formule, à savoir :

=TEXTE(E3;"jj/mm/aaaa")&" "&SI.CONDITIONS(ET(HEURE(E3)>=0;HEURE(E3)<1);"22h-01h";HEURE(E3)<4;"01h-04h";HEURE(E3)<7;"04h-07h";HEURE(E3)<10;"07h-10h";HEURE(E3)<13;"10h-13h";HEURE(E3)<16;"13h-16h";HEURE(E3)<19;"16h-19h";HEURE(E3)<22;"19h-22h";HEURE(E3)<=23;"22h-01h")

La formule commence donc par =SI.CONDITIONS(...

merci AntoineDL.

Rechercher des sujets similaires à "comment mettre deux composees heure date tranche horaire"