Charche une formule avec condition

Bonjour

J'ai un tableau avec des données que je rentre dans différentes cellules. je transpose des données d'acte de décès tout en essayant que la saisie se fasse rapidement.

Ci-joint un fichier qui donne une idée pour faire une fonction qui me regroupe plusieurs cellules. Pouvez-vous m'aider ? (excel2007)

4essais.xlsx (12.77 Ko)

Cordialement

Bonjour

Un exemple

Bonjour à toutes et tous !

Hello Joco7915

Une proposition qui devrait fonctionner avec Excel 2007 :

=SI(A2<>"";" -  " &A2;"") & " - " & B2 & SI(C2<>"";", Déclarant : " &C2&", "&D2&", "&E2&", "&F2;"") & SI(G2<>"";", et " &G2&", "&H2&", "&I2&", "&J2;"")

Je vous laisse le soin de l'adapter aux autres cellules présentes dans votre fichier.

re,

Merci pour cette aide précieuse. Vous m'avez enlever une grosse épine du pied. j'ai choisi la formule de JFL car elle prend en compte les cellules vides et c'est plus facile pour moi de la comprendre enfin un peu.

Mille merci

Cordialement

Bonjour de nouveau,

Merci de ce retour !

Rechercher des sujets similaires à "charche formule condition"