Caclul de la moyenne avec condition

je voudrais faire un suivi en calculant des moyennes avec la condition date, c'est pour avoir un historique par mois.

ci-joint le fichier.

merci

16moyenne.xlsx (11.07 Ko)

bonjour

un essai avec SOMMEPROD

19jsparo1.zip (9.06 Ko)

CORDIALEMENT

parfait,

merci beaucoup,

une dernière question : a quoi servent les deux tirés ?

Bonjour,

j.sparo a écrit :

une dernière question : a quoi servent les deux tirés ?

MOIS($A$5:$A$16)=MOIS(F$7) renvoie une matrice de VRAI, FAUX.

Les 2 tirets permettent de transformer ces VRAI/FAUX en 1/0, ce qui permet de les additionner.

On peut aussi remplacer les 2 tirets par 1* (multiplication par 1) ou encore par la fonction N().

Entre autres...

A+

thank's a lot

bonjour,

j'ai procédé à une petite modif des données,

j'ai ajouté une colonne "etat" qui va contenir opened et closed

Le but c'est de faire la moyenne avec les conditions : mois / année / etat

5jsparo1.zip (10.08 Ko)

bonojour

un essai : l'etat est un critere supplementaire

12jsparo2.zip (10.08 Ko)

cordialement

bonjour

ca marche, bravo et merci

Bonsoir,

le besoin a légèrement changé !

je voudrais ajouter le critère année et la montion "<=" au lieu "=" sur le fichier précédent.

l’explication du besoin est sur les infos bulles du fichier joint .

Merci d'avance

11jsparo3.zip (9.74 Ko)

Bonsoir,

c'est vraiment important les gars!!!

please help!!!

merci

Bonjour

En rajoutant tes 2 nouveaux arguments

tu ajouterais

*(MOIS($B$5:$B$16)<=MOIS(F$7))*(ANNEE($B$5:$B$16)<=ANNEE(F$7))

dans les 2 parties de la formule.

Pour tenir compte des cellules vides en colonne B, tu en ajoutes un 3ème

*(ESTNUM($B$5:$B$16))

Suite de quoi, ta formule en F8 deviendrait

=SOMMEPROD((MOIS($A$5:$A$16)=MOIS(F$7))*($C$5:$C$16)*(ESTNUM($B$5:$B$16))*(MOIS($B$5:$B$16)<=MOIS(F$7))*(ANNEE($B$5:$B$16)<=ANNEE(F$7))*($D$5:$D$16=$E8))/MAX(1;SOMMEPROD(--(MOIS($A$5:$A$16)=MOIS(F$7))*(MOIS($B$5:$B$16)<=MOIS(F$7))*(ESTNUM($B$5:$B$16))*(ANNEE($B$5:$B$16)<=ANNEE(F7))*($D$5:$D$16=$E8)))

Cordialement

Bonsoir,

désolé mais ça ne marche pas!

Je poste l'exemple avec les modifs apportées.

NOTA: Quand je compte manuellement la moyenne jusqu'à Janvier 2012 je trouve 79.8

Avec la formule il m'affiche : 43

je trouve cela bizarre .

merci d'avance pour votre aide.

8jsparo3.zip (10.09 Ko)

Bonjour

je trouve cela bizarre

.

Tu as raison!! C'est la 2ème partie de la formule qui est mauvaise

Formule en F8

=SOMMEPROD(($B$5:$B$16<F$7)*($D$5:$D$16=$E8)*(ESTNUM($B$5:$B$16));$C$5:$C$16)/MAX(1;SOMMEPROD(($B$5:$B$16<>"")*($B$5:$B$16<F$7)))

Cordialement

9jsparo3.zip (10.05 Ko)

Bonjour,

à priori ça marche!!

je te remercie pour ton aide,vraiment trop fort

Cdt

Rechercher des sujets similaires à "caclul moyenne condition"