Addition(critere 1 ET critere 2 ET (critere 3 OU critere 4))

Bonjour le forum,

Je dois additionner les valeurs d'un colonne en fonction de critères.

Pour être plus clair:

somme(citere1 dans colonne 1 ET critere 2 dans colonne 2 ET (critere 30 dans colonne 3 OU critere 31 dans colonne 3)

Dans le fichier ci-joint, j'ai essayé avec la fonction

SOMMEPROD()

j'ai un chiffre en retour, mais il ne correspond pas à la somme.

Peut-être est-il possible de le faire avec

SOMME.SI.ENS()

mais je ne sais pas comment intégrer la fontion

OU()

Merci d'avance pour votre aide

32classeur1.zip (5.53 Ko)

Bonjour

d'après ce que j'ai compris et le contenu de ton fichier, ci joint une proposition, avec somme.si.ens() à tester

Cordialement

FINDRH

35sommecond.zip (6.46 Ko)

bonjour

=SOMMEPROD(((A1:A106=F1)+(A1:A106=F4));--(B1:B106=G1);C1:C106)

=111 ;jai verifié

cordialement

Merci FINDRH pour ta réponse, mais ça ne correspond pas çà mon besoin, parce que je dois avoir la réponse dans une seule cellule.

Par compte, tulipe_4, ta formule correspond parfaitement. J'ai réussi à l'adapter, mais je ne comprend pas comment elle est construite.

D'habitude, j'utilise SOMMEPROD() ainsi:

SOMMEPROD((palge 1 = critere 1)*(plage 2 = cirtere 2)*((plage 3 = critere 30)+(plage 3 = critere 31))

Et dans ta formule, point de " * " mais des " ; " pour séparer "ET" et "OU" et la plage de somme

Que signifie "--"?

Merci d'avance

bonjour

astuce

tu remplaces les * par des ; lors de la construction de la formule ainsi ,comme tu sais ce qui doit donner 1 ; tu vas vite voir ce qui ne gaze pas ; souvant acause de ( ) omises ou mal placées

rappel : les 1 doivent etre alignés

les -- c'est pour convertir vrai en 1 ( c'est plus facile pour visualiser la concordance des 1

cordialement

Rechercher des sujets similaires à "addition critere"