compter nbre de dates differentes en fonction

Y compris Power BI, Power Query et toute autre question en lien avec Excel
b
bidochon34800
Membre fidèle
Membre fidèle
Messages : 181
Appréciation reçue : 1
Inscrit le : 20 novembre 2011
Version d'Excel : 2016

Message par bidochon34800 » 11 juin 2017, 06:46

bonjour à tous et toutes,
Je cherche à compter le nombre de dates différentes de la colonne "C" en fonction d'un critère de la colonne "E", soit dans l'exemple joint "LCT" = 3 et "LB"= 2.
J'ai trouvé diverses réponses au travers des forums que j'ai essayé d'adapter à mon cas.
J'ai réussi à afficher le nombre total de dates différentes, mais je n'arrive pas à faire la différenciation entre "LCT" et "LB".
Quelqu'un peut-il m'aider ?
Merce et bon dimanche !
essai.xlsm
(9.05 Kio) Téléchargé 31 fois
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'659
Appréciations reçues : 251
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 11 juin 2017, 08:24

bonjour

avec un TCD
il faut 30 secondes et aucun calcul ni VBA

j'ai ajouté qq lignes et mis sous forme de tableau (très pratique)
Copie de essai-2.xlsm
(13.07 Kio) Téléchargé 11 fois
Apprenez les fonctions d'Excel.
Exemple "Mettre sous forme de tableau", TCD, "Récupérer des données".
Apprendre les fonctionnalités "récentes".
Avatar du membre
waard
Contributeur
Contributeur
Messages : 436
Appréciations reçues : 16
Inscrit le : 9 février 2015
Version d'Excel : 2013, 2016, FR
Téléchargements : Mes applications

Message par waard » 11 juin 2017, 08:27

Hello,

2e solution avec NB.SI ça va bien aussi :wink:
Copie de essai.xlsm
(11.06 Kio) Téléchargé 18 fois
"One and yet a mass"
COHENNY Tristan - Projet MYRMIDON
b
bidochon34800
Membre fidèle
Membre fidèle
Messages : 181
Appréciation reçue : 1
Inscrit le : 20 novembre 2011
Version d'Excel : 2016

Message par bidochon34800 » 11 juin 2017, 08:35

Merci à jmd et haard pour les solutions proposées.
Perso, j'opte pour la deuxième solution car je ne connais pas encore les TCD et je ne comprends pas comment l'adapter à mon cas personnel.
Merci encore à tous les deux, et bon vote...
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'201
Appréciations reçues : 445
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 11 juin 2017, 08:56

Bonjour, Bonjour à tous,

Tu prenais des chemins détournés avec FREQUENCE... :D
=SOMME(SI(FREQUENCE(C2:C6;LIGNE(INDIRECT(MIN(C2:C6)&":"&MAX(C2:C6))))>0;1))
pour le nombre de dates différentes
=SOMME(SI(FREQUENCE(C2:C6*(E2:E6="LB");LIGNE(INDIRECT(MIN(C2:C6)-1&":"&MAX(C2:C6))))>0;1))-1

=SOMME(SI(FREQUENCE(C2:C6*(E2:E6="LCT");LIGNE(INDIRECT(MIN(C2:C6)-1&":"&MAX(C2:C6))))>0;1))-1
pour le nombre de dates différentes sous condition.

Toutes matricielles.

Cordialement.
b
bidochon34800
Membre fidèle
Membre fidèle
Messages : 181
Appréciation reçue : 1
Inscrit le : 20 novembre 2011
Version d'Excel : 2016

Message par bidochon34800 » 11 juin 2017, 13:14

OK merci aussi
je teste dès que je rentre ce soir.
Je tiens au courant.
Merci
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'294
Appréciations reçues : 191
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 11 juin 2017, 13:43

bonjour
une contribution dominicale
bidochon.xlsx
(10.52 Kio) Téléchargé 10 fois
cordialement
c'est en cherchant qu'on trouve
b
bidochon34800
Membre fidèle
Membre fidèle
Messages : 181
Appréciation reçue : 1
Inscrit le : 20 novembre 2011
Version d'Excel : 2016

Message par bidochon34800 » 11 juin 2017, 13:49

un grand merci à MFerrand,
c'est exactement ce que je voulais, et en plus ça marche impeccable !
profond respect
merci encore,
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message