Compter nbre de dates differentes en fonction

bonjour à tous et toutes,

Je cherche à compter le nombre de dates différentes de la colonne "C" en fonction d'un critère de la colonne "E", soit dans l'exemple joint "LCT" = 3 et "LB"= 2.

J'ai trouvé diverses réponses au travers des forums que j'ai essayé d'adapter à mon cas.

J'ai réussi à afficher le nombre total de dates différentes, mais je n'arrive pas à faire la différenciation entre "LCT" et "LB".

Quelqu'un peut-il m'aider ?

Merce et bon dimanche !

35essai.xlsm (9.05 Ko)

bonjour

avec un TCD

il faut 30 secondes et aucun calcul ni VBA

j'ai ajouté qq lignes et mis sous forme de tableau (très pratique)

Hello,

2e solution avec NB.SI ça va bien aussi

34copie-de-essai.xlsm (11.06 Ko)

Merci à jmd et haard pour les solutions proposées.

Perso, j'opte pour la deuxième solution car je ne connais pas encore les TCD et je ne comprends pas comment l'adapter à mon cas personnel.

Merci encore à tous les deux, et bon vote...

Bonjour, Bonjour à tous,

Tu prenais des chemins détournés avec FREQUENCE...

=SOMME(SI(FREQUENCE(C2:C6;LIGNE(INDIRECT(MIN(C2:C6)&":"&MAX(C2:C6))))>0;1))

pour le nombre de dates différentes

=SOMME(SI(FREQUENCE(C2:C6*(E2:E6="LB");LIGNE(INDIRECT(MIN(C2:C6)-1&":"&MAX(C2:C6))))>0;1))-1

=SOMME(SI(FREQUENCE(C2:C6*(E2:E6="LCT");LIGNE(INDIRECT(MIN(C2:C6)-1&":"&MAX(C2:C6))))>0;1))-1

pour le nombre de dates différentes sous condition.

Toutes matricielles.

Cordialement.

OK merci aussi

je teste dès que je rentre ce soir.

Je tiens au courant.

Merci

bonjour

une contribution dominicale

17bidochon.xlsx (10.52 Ko)

cordialement

un grand merci à MFerrand,

c'est exactement ce que je voulais, et en plus ça marche impeccable !

profond respect

merci encore,

Rechercher des sujets similaires à "compter nbre dates differentes fonction"