Fonction pour afficher liste conditionnée par cellule Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
Hosni
Membre dévoué
Membre dévoué
Messages : 867
Appréciations reçues : 2
Inscrit le : 24 septembre 2011
Version d'Excel : 2013/2016

Message par Hosni » 16 février 2020, 14:25

Bonjour à tous
Merci de m'indiquer la fonction ou plus exactement la formule qui me permet d'afficher la liste des villes relative à chaque commercial dans la cellule I2.

Merci à tous.
Classeur1.xlsx
(9.73 Kio) Téléchargé 8 fois
La vie est une École, qui nous apprend tous les jours plus..., Plus on sait..., Moins on en sait...
B. Hosni
Avatar du membre
78chris
Passionné d'Excel
Passionné d'Excel
Messages : 4'996
Appréciations reçues : 378
Inscrit le : 9 juillet 2017
Version d'Excel : 2010 à 2019 + 365

Message par 78chris » 16 février 2020, 15:13

Bonjour
=SI(NBVAL(INDIRECT("Tableau14["&$I$2&"]"))>NBVAL($I$2:I2)-1;INDEX(INDIRECT("Tableau14["&$I$2&"]");LIGNE(A1));"")
Sinon 2 lignes de VBA
Chris
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
Confucius
Avatar du membre
Hosni
Membre dévoué
Membre dévoué
Messages : 867
Appréciations reçues : 2
Inscrit le : 24 septembre 2011
Version d'Excel : 2013/2016

Message par Hosni » 16 février 2020, 15:19

Bonjour 78chris;

Je teste et je reviens aussitôt vers vous.

Merci infiniment pour votre réponse.
La vie est une École, qui nous apprend tous les jours plus..., Plus on sait..., Moins on en sait...
B. Hosni
Avatar du membre
Zebulon2
Membre fidèle
Membre fidèle
Messages : 345
Appréciations reçues : 29
Inscrit le : 6 juillet 2019
Version d'Excel : Office 2019 FR

Message par Zebulon2 » 16 février 2020, 15:20

Bonjour à tous,
Bonjour 78chris,

Une autre solution.
Cordialement.
Classeur1.xlsx
(11.09 Kio) Téléchargé 2 fois
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'692
Appréciations reçues : 237
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 16 février 2020, 15:35

bonjour
une solution
hosni.xlsx
(10.56 Kio) Téléchargé 5 fois
cordialement
ou alors encore plus facile
DECALER(A$2;LIGNE(A1)-1;EQUIV(I$2;COMMEER0;0)-1;)
c'est en cherchant qu'on trouve
Avatar du membre
Hosni
Membre dévoué
Membre dévoué
Messages : 867
Appréciations reçues : 2
Inscrit le : 24 septembre 2011
Version d'Excel : 2013/2016

Message par Hosni » 16 février 2020, 17:10

Bonjour
Merci à vous tous pour vos réponses et solutions toutes parfaites.
Je vous transmet mon classeur, en fait les données sont placées sur une feuille a part que où doit se faire l'affichage.
Merci de me corriger
Merci à vous.
ESSAI LISTE FEP.xlsx
(13.08 Kio) Téléchargé 3 fois
La vie est une École, qui nous apprend tous les jours plus..., Plus on sait..., Moins on en sait...
B. Hosni
Avatar du membre
78chris
Passionné d'Excel
Passionné d'Excel
Messages : 4'996
Appréciations reçues : 378
Inscrit le : 9 juillet 2017
Version d'Excel : 2010 à 2019 + 365

Message par 78chris » 16 février 2020, 18:09

re
=SI(NBVAL(INDIRECT("Tableau14["&$A$2&"]"))>NBVAL($A$5:A5)-1;INDEX(INDIRECT("Tableau14["&$A$2&"]");LIGNE(A1));"")
Chris
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
Confucius
Avatar du membre
Hosni
Membre dévoué
Membre dévoué
Messages : 867
Appréciations reçues : 2
Inscrit le : 24 septembre 2011
Version d'Excel : 2013/2016

Message par Hosni » 16 février 2020, 18:21

Bonjour 78chris

Merci infiniment pour ta correction et ta précieuse aide.
Merci à tulipe_4 et à Zebulon2 pour leur contributions.

Sujet clos.


A bientôt.
La vie est une École, qui nous apprend tous les jours plus..., Plus on sait..., Moins on en sait...
B. Hosni
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message