Une colonne plutôt qu'une autre

Bonjour,

Je sèche ou je n'ai pas l'esprit clair ce soir, bref je ne trouve pas la bonne formule à mettre en place.

Je cherche la formule pour calculer un solde en cours d'exercice comptable?

Si la colonne "Facturation " est alimentée, elle prime sur la colonne "Engagement".

Si la colonne "Facturation est vide, la colonne "Engagement" prime sur la colonne "Facturation".

Voir l'exemple en fichier joint

Cordialement

6compta.xlsx (10.48 Ko)

Bonsoir ddetp88,

Un essai: .... colonne supplémentaire test avec en M4 :

=SI(ET(K4<>"";L4<>"");L4;SI(K4="";L4;SI(L4="";K4)))

à tirer vers le bas....

Cordialement,

Bonjour xorsankukai (on ne va pas te le piquer celui-ci )

Merci déjà d'avoir pris de ton temps pour répondre mais ta proposition ne répond pas à ma demande.

Il faut tenir compte des compte C1;C2 et C3.

Le résultat attendu sur la première ligne est 378 € et non 38 je crois selon ta proposition.

Peut-être d'autres auront une idée.

Cordialement

Re,

Pourtant en E21, j'ai bien 378 pour C1 ?

La colonne "Test" (qui peut etre masquée) retient la valeur souhaitée en fonction de tes critères.

Ensuite, à partir de cette colonne et en fonction du critère (C1 ou C2 ou C3), on fait la somme....à moins que je sois encore à coté de la plaque,

Tu voulais le résultat en F4 ?

@+

Ok, excuse moi je n'avais pas vu ton exemple.

Je ne souhaite pas de colonne intermédiaire.

Je viens de mettre cette formule qui fonctionne mais je pense qu'il doit y avoir plus simple.

=SOMMEPROD((J4:J18=D4)*(L4:L18=0)*(K4:K18)) + SOMMEPROD((J4:J18=D4)*(L4:L18<>"")*(L4:L18))

J'attends de voir si il y d'autres propositions.

En tout cas merci pour ton aide.

Cordialement

Ne sois pas désolé,

Bien vu le SOMMEPROD, , je n'y avais pas pensé.

Bonne continuation,

@+ sur le forum

Bonjour ddetp88, xorsankukai,

j'ai pas vérifié, mais il me semble que cette petite simplification de ta formule devrait marcher :

=SOMMEPROD((J4:J18=D4)*(L4:L18=0)*(K4:K18)+(J4:J18=D4)*(L4:L18<>"")*(L4:L18))

dhany

Bonjour Dhany,

Plus élégante assurément.

Merci pour cette solution que je vais conserver.

Cordialement

merci pour ton retour, et pour avoir passé le sujet en résolu !

bonne continuation !

dhany

Rechercher des sujets similaires à "colonne plutot"