Trouver le nom d'une valeur (référence)

10classeur1.xlsx (10.45 Ko)

Bonjour,

Je cherche j'ai inscrire ce que je souhaite dans mon fichier excel car il est difficile de l'expliquer sans image

Bonsoir yannick127, le forum,

Une possibilité...

En C12:

=SIERREUR(INDEX($B$5:$F$9;EQUIV(GAUCHE(A12;1);$A$5:$A$9;0);EQUIV(DROITE(A12;1);$B$4:$F$4;0));"")

A tirer vers le bas...

Oups ! J'ai lu trop vite, désolé,


[EDIT] : Bonsoir LouReeD, , super la formule,

Lorsque j'inscris 3 dans C12, je veux que excel indique la référence B-C de mon tableau. Bref, qu'il m'indique les coordonnées de la ligne et de la colonne ou se trouve le 3

Un essai via VBA...

La macro s'exécute à chaque modif. dans la plage C12:C20

2yannick127.xlsm (20.19 Ko)


Cordialement,

Bonsoir,

J'ai observer le fichier et je cherche le résultat inverse

Lorsque j'inscris 3 dans C12, je veux que excel indique la référence B-C de mon tableau. Bref, qu'il m'indique les coordonnées de la ligne et de la colonne ou se trouve le 3

Bonsoir,

formule en D12 à tirer vers le bas, qui prend en compte les valeurs en colonne C :
=INDEX($A$5:A$9;SOMMEPROD(($C$5:$F$9=$C12)*LIGNE($C$5:$F$9))-4)&"-"&INDEX($B$4:$F$4;SOMMEPROD(($C$5:$F$9=$C12)*(COLONNE($C$5:$F$9)-1)))

Le -4 et le -1 seront à adapter si la position de la matrice de recherche venait à être déplacée.

@ bientôt

LouReeD

Rechercher des sujets similaires à "trouver nom valeur reference"