Somme gauche droite

Bonjour a tous,

j ai une formule personnalisée (trouvée sur ce forum ou un autre je ne me souviens plus) qui ne me donne pas entierement satisfaction...

je souhaite sur une plage faire la somme des chiffres situés avant le "/" et apres le "/" . Je joins un fichier

Ma formule marche bien pour des chiffres entre 1 et 9, ensuite ne marche pas. Je vois bien que le probleme est au niveau

left(c.value,1) , je voudrais remplacer 1 par trouve("/";plage testée)-1, mais je n y arrive pas......

et pour la partie de droite, il faut que je remplace Right(c.Value, 1) par nbcar(plage testée)-trouve("/";plage testée)

ou alors en matricielle, j ai essayé aussi avec =SOMME(GAUCHE(A1:A30;TROUVE("/";A1:A30)-1)) mais sns plus de succes...

quelqu un a une idee ?

Merci

Bonjour,

Voici les nouvelles fonctions personnalisées à copier à la place des autres :

Function sommegauche(plage As Range)
    ADR = plage.Address
    For Each c In Range(ADR)
        If c.Value <> "" Then Total = Total + Left(c.Value, InStr(c, "/") - 1) * 1
    Next
    sommegauche = Total
End Function
Function sommedroite(plage As Range)
    ADR = plage.Address
    For Each c In Range(ADR)
        If c.Value <> "" Then Total = Total + Right(c.Value, Len(c) - InStr(c, "/")) * 1
    Next
    sommedroite = Total
End Function

Bonjour

Essaye ça et dit moi :

Sub extractionMots()
    Dim Tableau() As String
    Dim i As Integer

    On Error Resume Next
    For i = 1 To Range("A65000").End(xlUp).Row
        Tableau = Split(Cells(i, 1), "/")
        S1 = S1 + CDbl(Tableau(0))
        S2 = S2 + CDbl(Tableau(1))
    Next i

    MsgBox S1
    MsgBox S2

End Sub

bonjour

sans vba

4floreli.xlsx (8.76 Ko)

cordialement

super merci a vous 3, les 3 solutions marchent comme je voulais !

Merci bonne fin de journée a tous

Rechercher des sujets similaires à "somme gauche droite"