Simplification de formule trop longue

Bonjour à tous,

je n'arrive pas à simplifier une formule du fait de sa répétition:

=SI(X$9="W0";"";SI(AA4<=$I$10;SI(OU(AA4=$I$9;AA4=$I$9+7;AA4=$I$9+14;AA4=$I$9+21;AA4=$I$9+28;AA4=$I$9+35;AA4=$I$9+42;AA4=$I$9+49;AA4=$I$9+56;AA4=$I$9+63;AA4=$I$9+70;AA4=$I$9+77;AA4=$I$9+84;AA4=$I$9+91;AA4=$I$9+98;AA4=$I$9+105;AA4=$I$9+112;AA4=$I$9+119;AA4=$I$9+126;AA4=$I$9+133;AA4=$I$9+140;AA4=$I$9+147;AA4=$I$9+154;AA4=$I$9+161;AA4=$I$9+168;AA4=$I$9+175;AA4=$I$9+182;AA4=$I$9+189;AA4=$I$9+196;AA4=$I$9+203;AA4=$I$9+210;AA4=$I$9+217;AA4=$I$9+224;AA4=$I$9+231;AA4=$I$9+238;AA4=$I$9+245;AA4=$I$9+252;AA4=$I$9+259;AA4=$I$9+266;AA4=$I$9+273;AA4=$I$9+280;AA4=$I$9+287;AA4=$I$9+294;AA4=$I$9+301;AA4=$I$9+308;AA4=$I$9+315;AA4=$I$9+322;AA4=$I$9+329;AA4=$I$9+336;AA4=$I$9+343;AA4=$I$9+350;AA4=$I$9+357;AA4=$I$9+363;AA4=$I$9+370);"s";"");""))&SI($I$9=AA4;"d";"")&SI($I$10=AA4;"f";"")

Avez-vous une idée SVP?

D'avance merci,

N.

Bonjour,

Est-il possible d'avoir un fichier ? Et une explication de la manip' ? Merci

Bonjour,

D'après ce que j'ai compris, tu testes si la différence entre AA4 et I9 est un multiple de 7.

=SI(X$9="W0";"";SI(ET(AA4<=$I$10;MOD(AA4-$I$9;7)=0);"s";""))&SI($I$9=AA4;"d";"")&SI($I$10=AA4;"f";"")

A+

Bonjour

=SI(X$9="W0";"";SI(AA4<=$I$10;SI(ET(MOD(AA4;7)=MOD(I9;7);AA4<I9+371);"s";"");""))&SI($I$9=AA4;"d";"")&SI($I$10=AA4;"f";"")

Cordialement

merci de vos réponses, je peux avoir l’explication SVP?

Voici le fichier:

En fait, cela ne marche pas, les cases avant la date se voient également recevoir l'indication....

bonjour noelgigi,

essayez avec :

=SI(AV$10="W0";"";SI(AZ4<=$I$11;SI(ET(JOURSEM(AZ4;1)=JOURSEM(I10;1);AZ4<I9+371);"s";"");""))&SI($I$10=AZ4;"d";"")&SI($I$11=AZ4;"f";"")

j'éssaie d'envoyer le fichier...

9planning-2019.xlsx (93.19 Ko)
9planning-2019.xlsx (93.19 Ko)

Au passage,

1- évite les cellules fusionnées, il y a moyen de faire des MFC

2- n'emploie pas NO.SEMAINE, à remplacer par NO.SEMAINE.ISO

3- simplifie ton fichier !! explique ce que tu veux faire car cela ne vas pas du tout, je pense que tu prends une mauvaise direction avec une organisation de données bien trop complexe !! Il faudrait sans doute utiliser un EQUIV a minima ...

Bonjour à tous,

Bonjour Amadéus, njhub, OOoiste

je n'arrive pas à simplifier une formule du fait de sa répétition:

=SI(X$9="W0";"";SI(AA4<=$I$10;SI(OU(AA4=$I$9;AA4=$I$9+7;AA4=$I$9+14;AA4=$I$9+21;AA4=$I$9+28;AA4=$I$9+35;AA4=$I$9+42;AA4=$I$9+49;AA4=$I$9+56;AA4=$I$9+63;AA4=$I$9+70;AA4=$I$9+77;AA4=$I$9+84;AA4=$I$9+91;AA4=$I$9+98;AA4=$I$9+105;AA4=$I$9+112;AA4=$I$9+119;AA4=$I$9+126;AA4=$I$9+133;AA4=$I$9+140;AA4=$I$9+147;AA4=$I$9+154;AA4=$I$9+161;AA4=$I$9+168;AA4=$I$9+175;AA4=$I$9+182;AA4=$I$9+189;AA4=$I$9+196;AA4=$I$9+203;AA4=$I$9+210;AA4=$I$9+217;AA4=$I$9+224;AA4=$I$9+231;AA4=$I$9+238;AA4=$I$9+245;AA4=$I$9+252;AA4=$I$9+259;AA4=$I$9+266;AA4=$I$9+273;AA4=$I$9+280;AA4=$I$9+287;AA4=$I$9+294;AA4=$I$9+301;AA4=$I$9+308;AA4=$I$9+315;AA4=$I$9+322;AA4=$I$9+329;AA4=$I$9+336;AA4=$I$9+343;AA4=$I$9+350;AA4=$I$9+357;AA4=$I$9+363;AA4=$I$9+370);"s";"");""))&SI($I$9=AA4;"d";"")&SI($I$10=AA4;"f";"")

En attendant d'en savoir davantage !! une proposition ...

en AA10 :

=SI($K9="";"";SI(AA9=$I11;"départ";SI(AA9=$I10;"W0";SI(GAUCHE(DECALER(AA10;;-7);1)="W";"W"&STXT(DECALER(AA10;;-7);2;3)*1+1;""))))
Rechercher des sujets similaires à "simplification formule trop longue"