SI imbriqué qui ne fonctionne pas

Bonjour à toutes et tous, un de mes arguments ne fonctionne pas et je sèche... En C25, si le brut dépasse 1880€, c'est taxé à du 6.5%, en dessous de 25 ans, c'est du 0.5% sinon c'est 240€ mais un fichier vaut mieux qu'un long discours, je le joins, merci d'avance. Il ne prend pas en compte le < à 25 ans, il me donne soit du 6.5% soit du 240€....

Bonjour

Fichier retiré pour présence de données confidentielles

Cordialement

Bonjour,

C'est une question de format. Vous voyez 21 en Z12 mais en réalité le chiffre est plus important.

Pour excel l'année 2021 n'est pas égale à 21.

J'ai modifié votre formule en Z12 m

ais aussi celle en C22 car impossible d'additionner ""

EDIT : Fichier modifier suite à la remarque de Dan

Merci à Valentin pour toutes ces précisions et sorry Dan, c'est un fichier trouvé sur le web que j'ai testé avec mon antivirus et antimalware mais je ne savais pas qu'il contenait des données personnelles.

Bonjour

Essaie ça :

=SI(C18>1880;C18*0,065;SI(Z12<25;C18*0,005;240))

Bye e

Effectivement ma formule n'est pas juste, je prends juste les années de naissances.

Désolé !

Salut GmB; en fait Valentin a trouvé le problème; je trouvais bien 21ans dans la cellule mais elle était "personnalisée" en "a" donc en format "standard"; il trouvait toute autre chose !! Merci !!

Bye

JmB

Rechercher des sujets similaires à "imbrique qui fonctionne pas"