Renvoyer entête de colonne dans un tableau en fonction de 2 critères

Bonjour à tous,

Je viens vers vous pour savoir comment récupérer l'entête d'une colonne d'un tableau en fonction d'un critère dans la 1ère colonne.

Voici un fichier exemple pour illustrer mon problème

6classeur1.xlsx (11.69 Ko)

Merci d'avance pour votre aide,

Saslen208

Bonjour Saslen208

Pour moi il faut faire plusieurs recherches concaténées, d'abord la ligne, puis la date dans la ligne
cela nous donne un numéro de colonne, on récupère ensuite l'entête de la colonne

Voici la formule

=INDEX(Tableau1[[#En-têtes];[01]:[13]];EQUIV(B20;DECALER(Tableau1[[#En-têtes];[tab]];EQUIV(A20;Tableau1[tab];0);1;;13);0))

@+

Bonjour

=SIERREUR(INDEX(Tableau1[#En-têtes];1;EQUIV(B20;DECALER(Tableau1[[#En-têtes];[tab]];EQUIV(A20;Tableau1[tab];0);;1;NBVAL(Tableau1[#En-têtes])-1);0));"")

Bonjour,

Merci à vous 2, vos 2 formules fonctionnent.

Bravo

Rechercher des sujets similaires à "renvoyer entete colonne tableau fonction criteres"