Remplacer SI par une fonction ?

Bonjour,

J'ai mis en pratique une fonction VBA trouvée ici....mais mon tableur évolue.

La question porte si on peut

d'une part "afficher un chiffre négatif" en tapant une chiffre sans mettre un "-" SI etc...

et d'autre part, introduire dans une fonction VBA, l'équivalent de la fonction SI

Comme d'habitude, ci-joint un tableur plus explicite.

Cordialement

Bonjour

Tonthon a écrit :

Comme d'habitude, ci-joint un tableur plus explicite.

Encore une habitude qui se perd

RE,

Je suis quasiment certain d'avoir joint le tableur mais il y a eu un souci puisque je le retrouve enregistré sans l'extension Excel.

Du coup, il faut que je refasse complètement.....sans doute que demain.

Désolé

Cordialement

Bonjour,

En refaisant le tableur, je m’aperçois que je m'embarquais dans des complications et qu'il y avait une solution plus simple.

Tellement simple que je n'arrive pas à la mettre "en musique" , je bloque ce matin

A ma décharge, cela fait à peine 1 mois que j'ai basculé en Excel 2010.

C'est un SI ou SI .....

Tout est dit dans le tableur joint cette fois ci

Cordialement

12conditions.xlsm (17.57 Ko)

bonjour

un essai

13tonthon.zip (9.63 Ko)

cordialement

Bonjour

Ton fichier en retour :

Amicalement

Nad

Edit : Bonjour Tulipe

RE

Merci pour ces 2 réponses, formules différentes avec résultat identique.

Cela va m'éviter de cogiter et me fait gagner du temps

Excellent WE à tous

Tonthon

RE

Je continue dans la mise en forme de mon tableur.....

J'ai beau "bidouiller" la formule précédente -cela doit être proche- je ne retrouve pas la formule qui permettrait d'éviter des calculs intermédiaires cf tableur et de supprimer 2 colonnes inutiles.

Merci d'avance

Bonjour

Si tu veux obtenir 860 il te suffit de faire :

=SOMME(B9:B13)

Amicalement

Nad

re

=SOMMEPROD((A9:A13="A")*(B9:B13))-SOMMEPROD((A9:A13="V")*(B9:B13))*-1

=860

ou alors

=ABS(SOMMEPROD((A9:A13="A")*(B9:B13)+(A9:A13="V")*(B9:B13))*-1)

=860

si plus de valeur tu peux nommer les plages (insersion>>nom)

Edit ton fichier en retour

7tonthon-2.zip (11.32 Ko)

cordialement

Bonjour,

Je fais un retour groupé.

Pour Nad, j'ai été sans doute trop peu explicite....le but était de trouver 860 en ne passant pas par les 2 colonnes H I comportant des calculs intermédiaires SI etc..

Pour Tulipe_4, c'est cela.

Ceci dit, je comprends la première fonction.

==< Par contre, j'aimerais comprendre la seconde ...

j'apporte de plus le ABS ?

C'est la première avec "sommeprod" en moins dans la seconde partie ??

J'ai cherché ici mais pas trouvé de réponse...si tu as un lien "explicatif" je suis preneur.

Accessoirement, Tulipe me rappelle mon pays d'origine...

Excellent dimanche à tous.....avec une heure de plus en se levant à la même heure

Bonjour

Tonthon a écrit :

Pour Nad, j'ai été sans doute trop peu explicite....le but était de trouver 860 en ne passant pas par les 2 colonnes H I comportant des calculs intermédiaires SI etc..

Où vois-tu que dans la formule :

=SOMME(B9:B3)

sont utilisées les colonnes H et I ?

Tel que ton fichier est présenté, inutile de faire SOMMEPROD ; une simple SOMME répond à ta demande.

Par contre, si je me réfère à ton précédent post, tu peux avoir A V ou rien dans la colonne A.

La formule peut être :

=SOMME.SI(A9:A13;"<>""";B9:B13)

car

=SOMMEPROD((A9:A13="A")*(B9:B13))-SOMMEPROD((A9:A13="V")*(B9:B13))*-1

équivaut à écrire

=SOMMEPROD((A9:A13="A")*(B9:B13))+SOMMEPROD((A9:A13="V")*(B9:B13))

Autrement dit, tu additionnes les cellules de la colonne B (qui sont toutes positives) quand dans la colonne A on trouve A ou V

Amicalement

Nad

Rechercher des sujets similaires à "remplacer fonction"