Recherchev et resultat vide

Bonjour le forum,

je suis a la recherche d'une formule excel qui me permettrait de chercher des infos dans une base et en fonction du résultat afficherait certaines choses ... je suis arrivé a faire cette formule, mais je ne veux pas obtenir de N/A dans ma colonne si je ne trouve pas ce que je cherche ...

Le plus simple c'est de vous joindre mon fichier pour exemple.

Merci par avance pour votre aide

Laurent

14priorisation.xlsm (20.53 Ko)

bonjour,

si tu fais recherchev pour trouver "moi" dans un tableau il est normal qu'il ne trouve pas si tu le l'implemente pas

ta formule est bonne il faut juste ajouter moi et une date dans ta feuille 1

Cdt

Didier

Je suis pas tres doué sur excel mais quand meme, ça j'avais bien capté le truc ....

Je recherche une formule qui fasse que si "moi", n'est pas dans la liste precedente alors toutes les colonnes sont vides et si "moi" est bien dans la liste précédente dans ce cas, mes formules sont appliquées

Franchement j'ai bien rigolé en voyant ta réponse....

il faut aussi modifier ta formule en interne

=SI(A9="";"";(RECHERCHEV(A9;'inscriptions précédentes'!$A$2:$B$30;2;FAUX)))

cela evite le NA


lolo69490 a écrit :

Je suis pas tres doué sur excel mais quand meme, ça j'avais bien capté le truc ....

Je recherche une formule qui fasse que si "moi", n'est pas dans la liste precedente alors toutes les colonnes sont vides et si "moi" est bien dans la liste précédente dans ce cas, mes formules sont appliquées

Franchement j'ai bien rigolé en voyant ta réponse....

heureux de t'avoir fait sourir en ces temps morne cela fait toujour du bien

bin non, j'ai toujours le #N/A ....

=SI(ET(A9='inscriptions précédentes'!A9;'inscriptions précédentes'!B9<>"");(RECHERCHEV(A9;'inscriptions précédentes'!$A$2:$B$30;2;FAUX));"")

plus de Na, la recherche du vide doit se faire sur la feuille1 et ca arrange tout.

désolé, mais je comprends ce que tu m'expliques ...

1/ il faut que je colle cette formule ou ?

2/ si je dois la coller dans la feuille "inscription en cours", cela fonctionne bien, si j'ai pas le nom en feuil1. mais si j'inscris le nom en feuil1, les colonnes en feuil2 restent toujours vide.

je te l'avais dit, je suis pas très doué

Merci pour ta patience et ton aide

je me suis permis de faire une ou deux petit modif sur ton fichier

en esperant repondre a ton attente

Cdt

Didier

12priorisation-2.xlsm (18.35 Ko)

bonjour

en passant

=SI(NB.SI('inscriptions précédentes'!A$2:A$21;A2)>0;RECHERCHEV('inscriptions en cours'!A2;'inscriptions précédentes'!A:B;2;0);"")

cordialement

Did350 et Tulipe-4

je pense que je n'ai pas été assez clair.

La feuil1 "inscription précédente", me sert uniquement de base de données, je saisi ici les noms et prénoms des personnes qui sont parti les années précédentes.

Dans la Feuil2 "inscriptions en cours", c'est ici que tout doit se passer ... Je souhaite que si je saisis un nom et prénom et que si on le trouve dans la Feuil1, la feuil2 doit se remplir, si il est introuvable dans la Feuil1, dans ce cas, je souhaite que toutes les colonnes soient vides sauf la colonne "Retenu/Refusé" soit rempli avec "Retenu".

Voila ça sera peut etre plus clair comme ça...

Merci pour votre patience et votre aide.

Avec SIERREUR, cela règle ton problème :

Cela permet d'indiquer que si le résultat renvoie une erreur, alors on laisse la cellule vide.

Il suffit de modifier la formule de la colonne I (si la colonne A est vide -> I vide ; si A n'est pas vide et que B est vide -> "Retenu").

Cela te convient-il ?

Salut Totor41,

c'est exactement ce que je souhaitais ... bravo

un grand merci a tous pour votre aide.

Bonne soirée et a bientot surement pour de nouvelles aventures

Laurent

Rechercher des sujets similaires à "recherchev resultat vide"