Rechercher une valeur selon critéres

Bonjour,

Je voudrais rechercher une valeur dans un tableau et selon si elle est en dépenses l'afficher avec le "moins devant", sinon si elle est en "recettes" l'afficher normalement.

Ce tableau excel vous permettra surement de mieux comprendre mon problème.

Merci d'avance,

18test1.xlsx (8.58 Ko)

Bonjour,

Je ne suis pas vraiment sûr que le fichier permette de bien comprendre le sujet, si je me base uniquement sur ce qui est présent je propose la solution en pièce jointe qui ne fera sûrement pas l'affaire, mais essayons quand même.

Bonjour,

Non, c'était trop facile

Finalement, pour ceux que ça intéresse j'ai trouvé une adaptation de ce que je voulais :

10test1.xlsx (9.76 Ko)

Bonjour !

Une autre proposition :

=SOMMEPROD(B1:B26*SI(A1:A26="Dépenses";-1;1))

Bonjour,

Ça fonctionne mais dans le cas où la dépense = 1000 et la recette = 0, la formule affiche 1000 (normal).

Je voulais que ça affiche -1000 dans la cas ou c'est une dépense et 1000 dans le cas ou c'est une recette.

Bonjour de nouveau !

Ça fonctionne mais dans le cas où la dépense = 1000 et la recette = 0, la formule affiche 1000 (normal).

Je voulais que ça affiche -1000 dans la cas ou c'est une dépense et 1000 dans le cas ou c'est une recette.

Dans l'exemple précité, ma formule affiche bien -1000.......

6test1-2.xlsx (10.64 Ko)

Ha yes, exact ! pourtant j'avais copier/coller la formule.

Formule plus simple que la mienne

Merci

A la bonne heure.....

Merci du retour !

Rechercher des sujets similaires à "rechercher valeur criteres"