Recherche mot clés à partir d'une base de donnée "cellule"

Bonjour URGENT svp.

Je souhaiterai à partir d'une base de donnée, recherche un mot clés qui se trouve dans une phrase.

Attention la recherche doit être étendue, et on ne doit pas saisir le mot rechercher, mais aller chercher la cellule.

Fichier joint.

Je vous remercie infiniment.

Samco

bonsoir

une contribution

9samco.xlsx (9.98 Ko)

cordialement

Salut,

Voici une proposition basée sur des SI imbriqués :

=SI(NB.SI(A2;"*"&$H$2&"*")>0;$H$2;SI(NB.SI(A2;"*"&$H$3&"*")>0;$H$3;SI(NB.SI(A2;"*"&$H$4&"*")>0;$H$4;SI(NB.SI(A2;"*"&$H$5&"*")>0;$H$5;SI(NB.SI(A2;"*"&$H$6&"*")>0;$H$6;"")))))

Mais il y a peut-être une meilleure solution...

A+

H

salut my sweet lord

imagine qu'il y ait 50 refs dans la col H ,l 'armée de SI

cordialement

n'importe comment je vois poindre un truc VBA avec du "like"

Mille merci

vous êtes génial.

Une petite remarque, la réponse de TULLIPE est adaptée.

Quand ma celle A est vierge, il me trouve quand meme leroy merlin, je voudrais que la cellule soit vierge, si la recherche n'aboutit pas.

Autre demande svp ;

Est-il possible d'integrer une recherche V à votre formule en 1 fois, je souhaiterais avoir le COMPTE en réponse.

Objectif:

Cherche le mot clé, + recherchev qui donne le compte. en 1 formule.

merci d'avance, ci joint le fichier.

Samco

fichiers joint.

4test-v2.xlsx (9.71 Ko)

re

voila

13samco2.xlsx (10.02 Ko)

cordialement

Rechercher des sujets similaires à "recherche mot cles partir base donnee"