Nombre d'imbrications SI 2007/2003

Bonjour à tous

Dans le fichier joint, j'ai la formule :

=SI(J5="admis";"NON";SI(J5="recalé";"Rattrapage-ASSR2";SI(OU(J5="Défavorable";GAUCHE(L5;2)*1>=16;M5=3);"ASSR2";SI(H5="recalé";"Rattrapage-ASSR1";SI(OU(H5="Défavorable";ET(H5<>"admis";OU(GAUCHE(L5;2)*1>=14;M5=5)));"ASSR1";"NON")))))

On a donc 5 conditions (6 avec le NON quand les 5 autres ne sont pas vérifiées)

Ce fichier est créé sous 2007. Quand je veux le passer en 2003, voici le message que j'ai :

capture

Bien sûr, si je valide quand même et que j'ouvre à nouveau le .xls, les formules donnent =#VALEUR!

Une idée ?

36testassr.xlsx (54.35 Ko)

Amicalement

Nad

Bonsoir nad , forum,

Peut être une explication sur le fichier joint.

Solution obtenue par déduction ,mais je ne sais pas du tout si c'est bien cela.

Espérant t'avoir aidé.

Amicalement

44pour-nad.zip (31.14 Ko)

Bonsoir haonv

Merci d'essayer de m'aider.

Si on doit comptabiliser les ET et les OU, effectivement on dépasse les 7 imbrications.

Toutefois, voici une formule que j'ai sur un fichier 2003 et qui fonctionne. Ne cherche pas à la comprendre, c'est juste pour l'exemple du nombre d'imbrications.

=SI(A13="";"";

SI(A13="Forme";DROITE(B13;4);

SI(OU(A13="façonnage";A13="Façonnage_Unité");Z13*((1+SOMMEPROD((X12>=MajoPeri1)*(X12<MajoPeri2)*CoefPeri))*(1+AA12));

SI(ET(A13="DV";A14="Forme");Z13*(((1+SOMMEPROD((Q13>=MajoSurf1)*(Q13<MajoSurf2)*CoefSurf))+(SOMMEPROD((S13>=MajoRapport1)*(S13<MajoRapport2)*CoefRapport)))+(H14-1));

SI(A14="Forme";Z13*H14;

SI(OU(A13="Réno";A13="Survitrage");Z13+H14;

SI(ET(A13="DV";A14<>"Forme");Z13*((1+SOMMEPROD((Q13>=MajoSurf1)*(Q13<MajoSurf2)*CoefSurf))+(SOMMEPROD((S13>=MajoRapport1)*(S13<MajoRapport2)*CoefRapport)));

Z13)))))))

Il doit y avoir autre chose que je ne vois pas.

Amicalement

Nad

Bonsoir Nad, forum,

En décomposant la formule, je trouve une anomalie,

le 2 premières conditions ont l'air de se contrarier avec admis et Recalé

à voir !

Amicalement

Claude

22nad-si.zip (32.27 Ko)

Bonsoir Claude

Je ne comprends pas ce que tu veux dire avec : "Une des 2 colonnes devrait être FAUX".

J'ai trouvé une formule qui passe en 2003. J'ai inversé les conditions. J'ai même ajouté une condition pour avoir le même nombre de SI et ET/OU. La voici :

=SI(B5="";"";

SI(OU(ET(H5<>"admis";GAUCHE(L5;2)*1<14;M5<5);ET(H5="admis";OU(GAUCHE(L5;2)*1<14;M5<>5));J5="admis");"NON";

SI(J5="recalé";"Rattrapage-ASSR2";

SI(OU(J5="Défavorable";GAUCHE(L5;2)*1>=16;M5=3);"ASSR2";

SI(H5="recalé";"Rattrapage-ASSR1";

"ASSR1")))))

Je la mets sans retour à la ligne pour ceux qui voudraient la tester :

=SI(B5="";"";SI(OU(ET(H5<>"admis";GAUCHE(L5;2)*1<14;M5<5);ET(H5="admis";OU(GAUCHE(L5;2)*1<14;M5<>5));J5="admis");"NON";SI(J5="recalé";"Rattrapage-ASSR2";
SI(OU(J5="Défavorable";GAUCHE(L5;2)*1>=16;M5=3);"ASSR2";SI(H5="recalé";"Rattrapage-ASSR1";"ASSR1")))))

J'ai également essayer d'inverser les OU/ET dans la formule qui est en place dans le fichier ; elle devient :

=SI(J5="admis";"NON";

SI(J5="recalé";"Rattrapage-ASSR2";

SI(OU(J5="Défavorable";GAUCHE(L5;2)*1>=16;M5=3);"ASSR2";

SI(H5="recalé";"Rattrapage-ASSR1";

SI(OU(ET(H5<>"admis";OU(GAUCHE(L5;2)*1>=14;M5=5));H5="Défavorable");"ASSR1";

"NON")))))

Sans retour retour à la ligne :

=SI(J5="admis";"NON";SI(J5="recalé";"Rattrapage-ASSR2";SI(OU(J5="Défavorable";GAUCHE(L5;2)*1>=16;M5=3);"ASSR2";SI(H5="recalé";"Rattrapage-ASSR1";
SI(OU(ET(H5<>"admis";OU(GAUCHE(L5;2)*1>=14;M5=5));H5="Défavorable");"ASSR1";"NON")))))

Mais avec elle, toujours le message de trop d'imbrications.

En résumé : j'ai maintenant une formule qui passe en 2003, mais bon sang de bonsoir je voudrais comprendre pourquoi l'autre non !!!!

Je précise que toutes les formules données renvoient le bon résultat.

Amicalement

Nad

Bonjour à tous,

Voici ce que dit microsoft à propos des imbrications :

Microsoft a écrit :

Limites des niveaux d'imbrication

Une formule peut contenir jusqu'à sept niveaux d'imbrication. Lorsque la fonction B est utilisée comme argument de la fonction A, la fonction B est dite de second niveau. Les fonctions MOYENNE et SOMME, par exemple, sont des fonctions de second niveau, car elles correspondent à des arguments de la fonction SI. Une fonction imbriquée dans la fonction MOYENNE serait une fonction de troisième niveau, etc.

Nad, ta formule semble bien imbriquer plus de 7 niveaux de fonction. Une explication dans le fichier joint ?

40imbrications.xlsx (55.03 Ko)
26imbrications.zip (50.31 Ko)

L'enregistrement sous 2003 donne bien une erreur #VALEUR.

bonsoir a tous ,

un autre fichier qui pourrait peut etre aidé.

Amicalement

48pour-nad-2.xls (16.50 Ko)
Rechercher des sujets similaires à "nombre imbrications 2007 2003"