NB.SI ou SOMMEPROD. Compter une fois des valeurs doubles

Hello a tous,

J'ai un tableau qui recense l'installation d'un logiciel pour plusieurs clients sur plusieurs sites.

Je voudrais, svp, de l'aide pour une formule qui me compte pour un client donne le nombre de licences que jai besoin

Pour un client, j'ai un site qui s'appelle SITE avec 3 users, j'ai donc besoin d'une seule licence pour SITE

Si vous voulez bien jeter un coup d'oeil sur mon fichier, j'ai mis un tableau du resultat que je souhaite et aussi ce que j'ai essaye qui fonctionne que pour un client

(aussi, si possible j'aimerais bien une solution avec les dynamic arrays de 365 et une sans au cas ou je dois la porter sur un autre excel)

merci les gars

2ep-nb-si.xlsx (11.69 Ko)

Bonjour,

Pour compter les différentes valeurs, lorsqu'il y a des doublons, la formule est la suivante :

=SOMMEPROD(1/NB.SI(Site;Site))

Où Site est la colonne contenant les noms de Site... si j'ai bien compris.

Cdlt,

Salut 3GB

C'est ce que j'ai essayé, c'est l'idée mais comme je dois imbriquer deux critères ca complique les choses

Si tu veux bien jeter un œil a mon fichier, je pense que ce sera plus clair

Bonjour,

Avec cette formule ?

=SI(NB.SI.ENS($A$3:$A$13;"ABC";$C$3:$C$13;"Site")>0;1;0)

Cordialement,

BatorFreuh,

Ca fonctionne top, merci

Vive ce forum

edit: merci 3GB pour ton temps

Bonjour dani0388, 3GB,

A tester dans la fichier joint:

6dani0388.xlsx (11.84 Ko)

Cordialement.

Édit: Désolé pour la collision avec @BatorFreuh, que je n'avais pas vu.

Merci mdo100

effectivement même solution que que @BatorFreuh

Merci a tous pour votre temps et reactivite

Rechercher des sujets similaires à "sommeprod compter fois valeurs doubles"