NB.SI.ENS avec SI

Bonjour,

Je bloque sur un petit problème : Je ne veux pas que certaines données soient prises en compte par rapport à l'année (2018).

Je vous joins un fichier avec la formule que j'ai essayé de faire mais ne fonctionne pas

Merci pour votre aide.

13extract-annee.xlsx (10.68 Ko)

Bonjour,

Moi, les TCD, SOMMEPROD et autres formules matricielles ou à points, c'est comme le permis à points... Tout juste bon à faire marcher le commerce !

Habituellement je procède comme dans le fichier joint.

Avantage : Que tu aies 10 lignes ou 100 000 le recalcul ne dure pas une demi -heure !

A+

Hello,

Merci pour la réponse et la solution.

En revanche là c'est juste un petit fichier d'exemple mais je veux intégrer ce calcul dans un + gros fichier déjà bien chargé en colonne et en feuille ...

Y a-t-il une autre solution ?

Merci.

Bonjour,

Formule suivante en H2 et à copier vers le bas et vers la droite :

=SOMMEPROD(($A$2:$A$12=H$1)*($B$2:$B$12=$G2)*(ANNEE($C$2:$C$12)<>$O$2))

Formule à adapter bien entendu à ton cas réel.

Elle est bien cette solution

Par contre je ne comprends pas comment on multiplie du TXT par du TXT et cela ne nous renvoie pas d'erreur ...

Est ce que tu sais me dire stp ??

Merci.

En revanche là c'est juste un petit fichier d'exemple mais je veux intégrer ce calcul dans un + gros fichier déjà bien chargé en colonne et en feuille ...

C'est justement dans les gros fichiers que ce système trouve son avantage !

La feuille de calculs à pas besoin d'être visible. (On peut la masquer)

On peut prévoir d'autres arguments au lieu d'une d'une matrice de 5x2 tu prévois le maximum nécessaire. ou éventuellement on peut l'adosser avec un peut de VBA et là tu peux traiter une base de donnée nationale en pas plus de temps que celle-ci...

Alors que ton SOMMEPROD... sur 300 000 lignes : T'as le temps d'aller boire un café et de fumer quelques cigarettes... !

A+

Oui je sais bien et je suis d'accord avec toi.

Le problème c'est que le fichier a été fait avec des fonction type NB.SI.ENS ... et j'ai pas le temps de tout modifier

Et je ne suis pas sur d'avoir les compétences pour le faire ...

J'ai oublié la semaine

Je n'y arrive pas avec sommeprod

J'ai refait un fichier.

Merci

6avec-semaine.xlsx (13.37 Ko)

Bonjour le forum,

NO.SEMAINE ne s'utilise pas avec des plages.

5sommeprod.xlsx (13.21 Ko)

Bonjour,

C'est pas gagné, car numéro de semaine et mois vont difficilement ensemble !...

Cdlt.

9avec-semaine.xlsx (21.50 Ko)

Merci à tous,

Apparemment je vais être obligé d'ajouter une colonne

Merci pour votre aide

Apparemment je vais être obligé d'ajouter une colonne

Les apparences sont parfois trompeuses ...

ohhhh et beh !!! beau boulot mbbp !!!

Bon j'ai pas tout compris mais je vais etudier

Merci a toi mbbp.

Rechercher des sujets similaires à "ens"