Imbriquer "SI" et "ET" sous Excel

Bonjour,

J'aimerais imbriquer les fonctions "SI" et "ET" sous excel, comment faire? Je m'explique, j'aimerais déterminer entre quelles bornes se trouve la valeur d'une de mes cellule. Pour cela je voulais faire quelque chose comme "SI ma cellule>= première valeur ET ma cellule<deuxième valeur; 1; 0" afin que si la valeur de ma cellule est comprise entre les deux autres valeur alors 1 s'affiche et sinon 0 s'affiche.

Pour faire simple, voici ce que j'aimerais obtenir, si -0,2634 est la valeur à tester

-0,8 -0,6 -0,4 -0,2 0 0,2 0,4 0,6 0,8 1 1,2

-0,2634 0 0 1 0 0 0 0 0 0 0

J'espère avoir réussi à vous expliquer mon problème de facon assez explicite.

D'avance merci pour votre aide.

Bonjour,

=SI(ET(valeuràcomparer>=valeur1;valeuràcomparer<valeur2);1;0)

Tu as juste à mettre les bonnes cellules ou se trouvent tes valeurs dans la formule.

Cordialement,

Edit : à moins que toutes tes valeurs de bornes soient dans 1 seule cellule et que tu veuilles le résultat sous la forme 00100000 dans une seule cellule aussi ?

Si c'est ça, je pense qu'il va falloir passer par une macro, car par formule j'ai un peu peur que cela fasse à truc à rallonge.

Bonjour

Non, non..Zirak, la même formule pour 10 valeurs ou 1000

Exemple: La suite de nombre en A2:A12, le nombre à tester en C2

=C2&CAR(32)&REMPLACER(REPT("0 ";NBVAL(A2:A12));EQUIV(C2;A2:A12;1);1;1)

Cordialement

12classeur10.xls (14.50 Ko)

Merci, la fonction : =SI(ET($F$118>=Y82;$F$118<Z82);1;0) a parfaitement fonctionné

Bonjour Amadéus,

Je ne connaissais pas la fonction REPT(), effectivement cela permet de tout mettre dans la même cellule directement, en revanche le reste de la formule ne colle pas avec le résultat demandé.

Ta formule retourne -0,2634 0 1 0 0 0 0 0 0 0 0 0

alors qu'elle devrait retourner : -0,2634 0 0 1 0 0 0 0 0 0 0

Donc le digit 1 n'est pas au bon endroit, et tu as un 0 de trop à la fin.

Il veux une comparaison entre 2 bornes pas juste trouver la valeur la plus proche, donc pour 11 valeurs de comparaison, cela fait 10 tests + la valeur à comparer soit 11 chiffres, alors que tu en retourne 12.

Cordialement,

Rechercher des sujets similaires à "imbriquer"