Résultats pour "imbriquer"

38 résultats pour cette recherche

Bonjour à tous.

J'aimerais imbriquer 2 formules de données, dans une seul cellule, je m’explique, j'ai une liste déroulante qui s'intitule "AGENTS" et où des Prénoms sont afficher, la cellule suivante s'intitule "Outils", une série d'Outils est attribuer à chaque Agents, j'ai réussie à créer une liste d'outil qui ne concerne que le premier agents, via la fonction "Validation des données", mais j'aimerais créer une liste d'outils différentes pour un autre agents, et étant donner que la cellule est déja "Occuper" par une formule, je suis bloquez et sollicite votre aide..

Je met, un ficher pour illustrer mes propos.

Bien à vous

Hello tout le monde ! 😊

Toute débutante, je suis dans une impasse. 😥

Je cherche tout simplement à imbriquer les fonctions ESTVIDE et ESTNA de sorte que si ma cellule référence est vide, la cellule reste vide et si le code d'erreur #NA apparaisse, le message d'erreur "Code incorrect" apparaisse à la place.

Pour le moment tout fonctionne bien séparément mais impossible de tout mettre ensemble. 😞

=SI(ESTNA(RECHERCHEV(A9;tableau_produits;2;0);"Code incorrect";RECHERCHEV(A9;tableau_produits;2;0))

=SI(ESTVIDE(RECHERCHEV(A9;tableau_produits;2;0);"";RECHERCHEV(A9;tableau_produits;2;0))

Merci d'avance pour votre aide ! 😄

Bonjour,

Help ! J’ai besoin de votre précieuse aide !

J’ai un tableau avec une référence en cellule A

J’ai un second tableau avec ces mêmes références sur plusieurs lignes, en face de ces lignes il y a des chiffres

Je voudrais pouvoir renvoyer en cellule B de mon 1er tableau, la somme des lignes de mon 2nd tableau comportant cette même référence

Comment faire… ? Recherchev j’imagine mais probablement imbriquée ?

Et j’imagine aisément que mon explication n’est peut-être pas claire…

merci de votre aide

Lauriane

Bonjour j'ai un probleme sur une formule

test logique D15=""

valeur si vrai

SI(ET(D13=4;D5="M");"1M";SI(ET(D13=3;D5="M");"2M";SI(ET(D13=2;D5="M");"3M";SI(ET(D13=1;D5="M");"4M";SI(ET(D13=0;D5="M");"5M";SI(ET(D13=4;D5="A");"1A";SI(ET(D13=3;D5="A");"2A";SI(ET(D13=2;D5="A");"3A";SI(ET(D13=1;D5="A");"4A";SI(ET(D13=0;D5="A");"5A";SI(ET(D13=4;D5="N");"1N";SI(ET(D13=3;D5="N");"2N";SI(ET(D13=2;D5="N");"3N";SI(ET(D13=1;D5="N");"4N";SI(ET(D13=0;D5="N");"5N";SI(ET(D13=6;D5="M");"OK";SI(ET(D13=6;D5="A");"OK";SI(ET(D13=6;D5="N");"OK";SI(ET(D13=5;D5="M");"OK";SI(ET(D13=5;D5="A");"OK";SI(ET(D13=5;D5="N");"OK";SI(ET(D13=7;D5="N");"OK";SI(ET(D13=7;D5="A");"OK";SI(ET(D13=7;D5="M");"OK";""))))))))))))))))))))))))

valeur si faux

SI(ET(D13=5;D5="M");"1M";SI(ET(D13=4;D5="M");"1M";SI(ET(D13=3;D5="M");"3M";SI(ET(D13=2;D5="M");"4M";SI(ET(D13=1;D5="M");"5M";SI(ET(D13=0;D5="M");"6M";SI(ET(D13=5;D5="A");"1A";SI(ET(D13=4;D5="A");"2A";SI(ET(D13=3;D5="A");"3A";SI(ET(D13=2;D5="A");"4A";SI(ET(D13=1;D5="A");"5A";SI(ET(D13=0;D5="A");"6A";SI(ET(D13=5;D5="N");"1N";SI(ET(D13=4;D5="N");"2N";SI(ET(D13=3;D5="N");"3N";SI(ET(D13=2;D5="N");"4N";SI(ET(D13=1;D5="N");"5N";SI(ET(D13=0;D5="N");"6N";SI(ET(D13=6;D5="M");"OK";SI(ET(D13=6;D5="A");"OK";SI(ET(D13=6;D5="N");"OK";SI(ET(D13=7;D5="M");"OK";SI(ET(D13=7;D5="A");"OK";SI(ET(D13=7;D5="N");"OK";""))))))))))))))))))))))))

elle fonctionne parfaitement mais il faut que je rajoute au test logique si(OU(C2="lun";C2="mar";C2="mer";C2="jeu";C2="ven")

ET(D15="")

valeur vrai

valeur faux

comment j'ecris ca

merci

Bonjours , esque il est possible dans les formats de cellule ou peut etre en VBA de metre en place un formatage conditionelle pour des nombres.

J'aimera que si je entre un nombre a virgule, celui-ci simbrique dans un array automatiquement.

Example

4,20 => [4,20]
1,2 => [1,2]
24 => 25
a8j9wqvr o

La raison de ca, ces que je export au format CSV et ensuite j'utilise

JSON.parse()

qui format soit un nombre fini ou un array.

Bonjour à tous,

Je ne suis absolument pas douée avec le module VBA.

J'ai un fichier excel, utilisé par plusieurs personnes. Ce fichier je souhaite qu'il se ferme automatiquement avec sauvegarde après inactivité par l'utilisateur. Pour cela j'ai trouvé sur ce forum un code VBA qui fonctionne très bien (merci le forum https://forum.excel-pratique.com/viewtopic.php?t=60642).

MAIS, j'avais déjà dans mon fichier une autre macro pour que celui-ci s'ouvre systématiquement sur la page "accueil" de mon fichier excel qui comporte plusieurs feuilles.

Ma question est la suivante : comment faire pour "imbriquer" ces deux MACROS ?

Voici le code pour la MACRO fermer automatiquement au bout de 10mn le fichier avec sauvegarde

Dans "this work book"

Option Explicit

Private Sub Workbook_Open()

Call SetTimer

End Sub

Private Sub Workbook_BeforeClose(Cancel As Boolean)

Call StopTimer

End Sub

Private Sub Workbook_SheetCalculate(ByVal Sh As Object)

Call StopTimer

Call SetTimer

End Sub

Private Sub Workbook_SheetSelectionChange(ByVal Sh As Object, _

ByVal Target As Excel.Range)

Call StopTimer

Call SetTimer

End Sub

Dans "module1"

Option Explicit

Dim DownTime As Date

Sub SetTimer()

DownTime = Now + TimeValue("00:00:10")

Application.OnTime EarliestTime:=DownTime, _

Procedure:="ShutDown", Schedule:=True

End Sub

Sub StopTimer()

On Error Resume Next

Application.OnTime EarliestTime:=DownTime, _

Procedure:="ShutDown", Schedule:=False

On Error GoTo 0

End Sub

Sub ShutDown()

ThisWorkbook.Close SaveChanges:=True

'Application.Quit

End Sub

Voici le code pour la MACRO pour Toujours ouvrir le fichier sur la feuille ACCUEIL.

Elle est positionnée sur "This work book" :

Private Sub Workbook_Open()

ActiveWorkbook.Worksheets("ACCUEIL").Activate

End Sub

Je ne sais vraiment pas comment faire pour que les deux commandes fonctionnent.

Je suis nulle en VBA, merci pour votre aide.

Mille mercis

Bonjour,

Je cherche à obtenir un résultat avec deux conditions, je m'explique, j'ai un fichier de suivi de stock dans lequel je voudrais qu'il aille chercher en automatique les prévisionnelles pour chaque code article en fonction de la semaine.

Je voudrais qu'en face des articles dans les lignes "besoins" apparaissent les bons chiffres de l'onglet "prev Alpro" en fonction de la semaine.

Je ne sais pas si je me suis bien fait comprendre.

Merci par avance à ceux qui pourront m'aider

Bonjour à tous !

J'aimerai créer une fonction dans une cellule avec plusieurs conditions, et vu le nombre de conditions je ne sais pas si c'est réellement possible... Je m'explique :

J'ai une ligne EXCEL par logement :

  • 1 cellule qui contient la typologie du logement,
  • 1 cellule par diagnostic réalisé, où je "coche" tout simplement le type de diagnostic (j'ai 4 types, donc 4 cellules)
  • 1 dernière cellule qui contient le tarif total engagé par logement.

Sachant que les tarifs selon le type de diagnostic varient : j'aimerai connaitre le tarif total par logement, selon le nombre de diagnostics engagés (sachant que chaque type de diagnostic à son tarif, selon la typologie...).

Une capture écran du fichier se trouve en PJ pour être plus claire.

J'ai créé une première fonction SI pour connaître le tarif DPE par exemple (A2 étant la cellule où se trouve la typologie) : =SI(A2>=7;40;SI(A2>=5;38;SI(A2>=3;32;SI(A2>=1;25;0))))

Mais il faut que j'ajoute à cela "si la cellule E2 est cochée ("X"). Et je n'y arrive pas car je n'ai pas vraiment de valeur si vrai si faux finalement...

Quelqu'un a la solution ?

Merci beaucoup pour votre aide et bon dimanche à tous !

capture

Bonjour

Je souhaiterai imbriquer deux formules dans une cellule, je ne sais pas si c'est possible ni comment l’écrire.

En C1 le résutat d'un formule mathématique simple de type : =B1/365,25 la cellule C1 à donc une valeur X

Je souhaiterai que la cellule C1 prenne la valeur de 0 en fonction d'un autre calcul dont le résultat serait en D1elle même résultat d'une formule =SI(K8>=$O$2;1;0)

tel que si D1 = 0 alors C1 = 0

Ce qui reviendrai à imbriquer C1 = B1/365.25 et si D1 = 0 alors C1=0

Est-ce possible et comment l’écrire, j'ai tenté plusieurs écritures notamment avec & mais sans succès

Merci

Bonjour,

j'ai un problème avec deux si imbriqués

voici ma formule : =SI(A4="GROUILLER";30;SI(A4="BERTRAND";2;SI(A4="ZANINI";5;)))

Dans un tableau, je voudrais mettre la valeur 30 si c'est une personne, si c'est une autre mettre 2 et si ce n'est ces personnes là mettre aucune valeur donc un blanc.

En l'état actuel des choses la formule fonctionne bien, sauf qu'au lieu d'un blanc j'ai la valeur 0.

Si je mets cette formule là : =SI(A4="GROUILLER";30;"";SI(A4="BERTRAND";2;"";SI(A4="ZANINI";5;""))) elle est refusée nombre trop important d'argument.

Pourriez vous m'aider s'il vous plaît?

Merci

Cordialement.

Didier

Salut

Prière de l'aide

dans le cadre de traitement des éléments de la paie, si un employé fait un déplacement et il n'a pas bénéficié d'un bon d’hébergement "BH" à l’hôtel on lui accorde:

1)si la durée du déplacement > 7h on lui accorde 1repas

si la durée du déplacement > 14h on lui accorde 2repas

si la durée du déplacement > 14h on lui accorde 2 repas + 1 Découche

2) si l'employé a une indemnité panier "IP" et il a un 1R ou 2R ou 2R+1D alors on lui retranche

automatiquement "-1P"

je cherche à résoudre la deuxième hypothèse

Merci bien pour tous

SIGA

si imbrique

Bjr

Je sollicite votre aide pour imbriquer des fonctions "si" dans un fichier qui sera actualisé tous les mois à partir de deux autres fichiers sources.

Dans la case F, je souhaite imbriquer les fonctions SI suivantes:

SI E2= "NOU" et K2<3 alors F2= "NOU" sinon F2="GAM"

SI E2= "GAM" et N2>0 alors F2= "GAM" sinon F2="FIN"

SI E2="FIN" et N<0 alors F2="FIN" sinon F2="GAM"

En vous remerciant pour votre aide, j'ai cherché de mon côté mais je suis bloqué

Thx

9test.zip (85.31 Ko)

Bonjour à Tous,

Je voudrais comparer la valeur de 2 cellules.

Si dans ma colonne A et B, la valeur de la cellule A2 etB2 sont = à "site A" alors "1"

MAIS SI:

la valeur de la cellule A2 etB2 sont = à "site B" alors "2"

SI ces conditions sont fausses alors "0"

mais là je pêche, si vous avez une idée à cela, je vous remercie.

cordialement,

Bouddha62

16formulesi.xlsx (27.52 Ko)

Bonjour,

j'ai besoin d'aide pour une formule excel. Je veux associer une année à un cycle, j'en répertorie 3. Par exemple cycle 1 correspond à 2015, 2012; cycle 2 à 2016, 2013, 2010 et cycle 3 à 2017, 2014 et 2011. (je remonte jusqu'à 1989)

Je ne sais faire ma formule que pour un cycle, =(SI(OU(G21=15;G21=12;G21=9;G21=5;G21=2;G21=99;G21=95;G21=92;G21=89;G21=85);"cycle1";"")), comment intégrer les autres cyles?

Si les années ne correspondent pas à cycle 1, alors tester les années pour le cycle 2 et enfin le cycle 3.

Merci pour votre aide.

Anaïs

Bonjour,

j'ai une formule avec 6 conditions, je dois les faire fonctionner les 6. pour le moment seulement les deux premières conditions qui fonctionnent. et j'ai pas de message d'erreur. pouvez vous m'aider a imbriquer ces 6 formules. Merci d'avance

cette formule et tapé dans la colonne M.

je vous joint le fichier excel

=SI(Q8="C";SI(K8="";"";SI(L8>G8;(ENT(K8-F8)*24)+HEURE(L8-G8);(ENT(K8-F8)*24)-HEURE(G8-L8)));SI(Q8="";SI(K8="";"";SI(L8>U8;(ENT(K8-T8)*24)+HEURE(L8-U8);(ENT(K8-T8)*24)-HEURE(U8-L8)));SI(Y8="passage de critique à prio 1";SI(K8="";"";SI(L8>U8;(ENT(K8-T8)*24)+HEURE(L8-U8);(ENT(K8-T8)*24)-HEURE(U8-L8)));SI(Y8="passage de prio 1 à critique";SI(K8="";"";SI(L8>G8;(ENT(K8-F8)*24)+HEURE(L8-G8);(ENT(K8-F8)*24)-HEURE(G8-L8)));SI(Y8="pas d'évolution";SI(K8="";"";SI(L8>AA8;(ENT(K8-Z8)*24)+HEURE(L8-AA8);(ENT(K8-Z8)*24)-HEURE(AA8-L8)));SI(Y8="passage de critique ou P1 à aucune priorité";"RAS"))))))

si vous voulez en détail de chaque condition voila:

condion 1 : =SI(Q8="C";SI(K8="";"";SI(L8>G8;(ENT(K8-F8)*24)+HEURE(L8-G8);(ENT(K8-F8)*24)-HEURE(G8-L8))))

condition 2 : =SI(Q8="";SI(K8="";"";SI(L8>U8;(ENT(K8-T8)*24)+HEURE(L8-U8);(ENT(K8-T8)*24)-HEURE(U8-L8))))

condition 4 : =SI(Y8="passage de critique à prio 1";SI(K8="";"";SI(L8>U8;(ENT(K8-T8)*24)+HEURE(L8-U8);(ENT(K8-T8)*24)-HEURE(U8-L8))))

condition 3 : =SI(Y8="passage de prio 1 à critique";SI(K8="";"";SI(L8>G8;(ENT(K8-F8)*24)+HEURE(L8-G8);(ENT(K8-F8)*24)-HEURE(G8-L8))))

condition 5 : =SI(Y8="pas d'évolution";SI(K8="";"";SI(L8>AA8;(ENT(K8-Z8)*24)+HEURE(L8-AA8);(ENT(K8-Z8)*24)-HEURE(AA8-L8)))

condition 6: =SI(Y8="passage de critique ou P1 à aucune priorité";"RAS")

Bonjour,

Dans Excel, existe-t-il d'imbriquer 2 RechercheV avec 1 RechercheH ?

Si oui, comment faire ?

Merci

Bonsoir,

je sollicite votre aide car oui, à cette heure ci je n'ai toujours pas trouvé la bonne formule, je suis totalement novice en Excel et ce sujet est un devoir que je doit rendre, pouvez m'aidez à trouver la bonne association de fonction?

j'ai tenté celle-ci en dernier =CONCATENER(MS;SI(B23>=10;0;SI(B23<0;0;""));GAUCHE(I23;5)) mais c'est toujours pas ça.

voila la consigne:

l'IDMS doit appliquer le code suivant : les lettres M et S + IDMED au format 00 (ce format est automatique si l'IMED est composé de 2 chiffres donc s'il est > ou = à 10 Si IDMED<10, le logiciel doit renvoyer "0" devant; ainsi l'IDMS de M.MORA sera MS1917010 et celui de Mme DURIEUX, MS0922802) + les 5 premiers chiffres du numero de SS.

j'espère avoir réussi à me faire comprendre, car je m'y perd moi-même. je joint le DOC

19classeur1.xlsx (14.68 Ko)

Merci de votre aide

Bonjour,

Voici mon problème,

J'ai un fichier avec en colonne des numéros de sociétés (qui peut varier), en lignes j'ai des numéro de compte (qui peut varier aussi) et au milieu les soldes des comptes.

Je souhaite créer une macro qui va créer un nouveau tableau dans un nouvel onglet. ce tableau doit récupérer en boucle le numéro de la société, le numéro de compte et la valeur associée.9a me fait du coup plus de données mais c'est le seul moyen pour le retravailler derrière.

Je vous joins mon fichier avec ma macro qui ne fonctionne qu'à moitié.

Merci d'avance pour votre aide car je suis perdu!!

19test2.xlsm (21.45 Ko)

Bonjour,

Je suis nouveau sur le forum et j'admire l'aide qui y est apportée.

Ce qui me frappe, c'est que tous les experts qui volent à notre secours savent IMBRIQUER les fonctions.

Pouvez-vous me conseiller des ressources gratuites pour apprendre à imbriquer les fonctions ?

Cela me sera d'une grande utilité.

Merci.

Bonjour à tous,

Je n'ai pas l'impression que la solution mon problème soit bien compliquée, mais je n'arrive pas à la trouver.

J'ai un document excel avec 2 feuilles ( document joint)

Sur la première (Base) il y a en colonne les noms et prénoms de personnes puis les mois de janvier à décembre 2014 ( les mêmes prénoms et noms apparaissent plusieurs fois car chaque ligne correspond à une période d'absence).

J'aimerais pouvoir faire dans la seconde feuille la somme des jours ouvrés par personne pour chaque mois.

Par exemple, en E3 ( Janvier 2014, MICHEL Pierre) il faudrait obtenir le nombre 9 ( 2+7).

J'ai essayé avec les fonctions somme.si, somme.si.ens, rechercheV, rechercheH mais sans succès.

N'étant pas une pro d'excel une erreur de ma part est fort possible !

Je me disais qu'imbriquer une fonction somme.si et rechercheV pourrait peut être marcher mais je n'ai aucune idée de la manière de faire!

Merci d'avance pour votre aide!

Bonne journée

79suivi-absences.xlsx (13.48 Ko)

Recherches récentes

code couleur vbacode couleurcontientqueryusfmasquer lignes filtreshourpmucalcul satisfaction clientcsv recherche vbavba stextrecherche csvcsv rechercheliste deroulantecongeparc autosatisfaction clientscrollbar listboxmodesteloto