Frais de port avec la formule SI

Bonjour,

Sur ma facture, je dois calculer le montant des frais de port en fonction du montant total HT, en utilisant la fonction SI.

Pour un montant entre 0 et 100 euros, il y a 20 euros de frais de port.

Entre 100 et 200 euros, il y a 15 euros de FDP.

Entre 200 et 300 euros, il y a10 euros de FDP.

Entre 300 et 500 euros, il y a 5 euros de FDP.

Au-delà de 500 euros, il n'y a plus de frais de port.

Aussi, pouvez-vous m'aider en utilisant la formule SI ? Je ne parviens pas à ce qu'elle soit juste.

Merci d'avance.

Bonjour et bienvenue sur le forum,

Un essai en PJ
J'ai considéré que jusqu'à 100€ compris les FDP sont de 20€, >100€ jusqu'à 200€ compris sont de 15€, >200€ jusqu'à 300€ compris sont de 10€, >300€ jusqu'à 500€ compris sont de 5€ et gratuits si >500€.
cdt

Henri

bonsoir

La valeur à contrôler en B2

=SI(B2<=100;20;SI(B2<=200;15;SI(B2<=300;10;SI(B2<=500;5;0))))

bonjour

a tester

=CHOISIR(EQUIV(Tableau1[[#Cette ligne];[Prix]];{0;100;200;300;500;100000};1);20;15;10;5;0)

bonjour, j'ai résolu mon problème en faisant: =SI(ET((F30)<100);20;SI(ET((F30)<200);15;SI(ET((F30)<500);10;SI(ET(500<=(F30));5;FAUX))))

Bonjour Pincelle, tulipe_4 et CB60

Voici une synthèse des solutions proposées.

AFEH et CB60 ont le même résultat, tulipe_4 un autre et Pincelle encore un autre mais au delà de 300 j'ai un doute.

Cdt

Henri

Rechercher des sujets similaires à "frais port formule"