Formule ou code pour compter le changement de couleur

Bonjour

Tout est dans le titre et dans le fichier

Merci pour votre aide

7mfc-speciale.xlsx (12.83 Ko)

Bonjour,

Dans n'importe quelle cellule :

=SOMMEPROD(($A$2:$D$4<>$A$14:$D$16)*1)

Cdlt,

Bonjour Ergotamine

Merci pour ta réponse mais elle ne va pas,surement a cause d'une erreur de ma part

j'ai rectifier les MFC et je remet mon fichier

je ne sais pas si ma demande est possible

4mfc-speciale.xlsx (13.42 Ko)

Bonjour,

La version updatée :

=SOMMEPROD(($A$2:$D$4<>$A$14:$D$16)*($A$2:$D$4<>"")*1)

Par contre que veut dire "le total d'erreur doit se cumuler" ? Si l'on remplace 12 par 13, alors le compteur doit passer à 2 ? Dans ce cas il faudrait passer par macro événementielle en insérant ce code dans le module de la feuille :

Private Sub Worksheet_Change(ByVal Target As Range)
If Target.DisplayFormat.Interior.Color = 255 Then Range("F5") = Range("F5") + 1
End Sub

Cdlt,

J'ai mis en place dans mon fichier original

j'ai un message qui me dit: espace pile insuffisant

Comment remédier à cela

Le bug est ici

Range("O5") = Range("O5") + 1
Private Sub Worksheet_Change(ByVal Target As Range)
If Target.DisplayFormat.Interior.Color = 255 Then Range("O5") = Range("O5") + 1
End Sub

Bonjour,

Là j'ai peur d'arriver à ma limite de connaissances. J'aurai tendance à dire que mon code est "sale" du fait d'une cellule qui s'additionne sur elle même. Peut être tester que la cellule modifiée n'est pas O5, mais si ça ne fonctionne pas, je n'aurais pas d'autres idées désolé :

Private Sub Worksheet_Change(ByVal Target As Range)
If Application.Intersect(Target, Range("O5")) Is Nothing And Target.DisplayFormat.Interior.Color = 255 Then Range("O5") = Range("O5") + 1
End Sub

Cdlt,

Merci pour ton aide avec quelques modif cela fonctionne

Cordialement

Rechercher des sujets similaires à "formule code compter changement couleur"