Formule Excel ou code VBA : POUR REMPLIR UN TABLEAU

Bonjour a tous le monde,

J'ai besoin de votre aide, je travaille régulièrement avec des base de données qui me prend beaucoup de temps, Pouvez vous m'aider a trouver la formule Excel ou un code vba, qui me permettrais de ranger des données automatiquement dans un tableau ( voir mon tableau en pièce jointe)

je vous remercie pour aides

Bien merci a vous ....

13base-de-donnee.xlsm (20.26 Ko)

Bonjour Excel38 ,

  1. Une formule matricielle en J15 à recopier vers le bas jusque vers J23 (la cellule J15 est dotée d'une MFC)
  2. puis copier la plage J15:J23 vers la droite jusqu'à obtenir une colonnes de cellules "vides"

La formule matricielle en J15 est à valider par Ctrl+Maj+Entrée (sauf pour les récentes versions d'Excel) :

=SI(COLONNES($A:A)>NBVAL($B15:$H15)*4;"";SIERREUR(SI(MOD(COLONNES($A:A);4)=1;INDEX(15:15;PETITE.VALEUR(SI($B15:$H15<>"";COLONNE($B15:$H15);"");1+ENT((COLONNES($A:A)-1)/4)));"ref");""))
image

..

Bonjour

Bonjour à tous

Un essai avec macro

Bye !

Re,

@gmb que je salue . Comme j'avais commencé, je publie ...

cliquer sur la flèche Hop!

  1. quand on vous le demandera, sélectionner la plage source
  2. quand on vous le demandera, sélectionner la cellule cible (cellule du coin haut gauche de la plage cible)

Le code est dans module1.

Bonjour je vous remercie vraiment pour votre aide sa marche très bien

Rechercher des sujets similaires à "formule code vba remplir tableau"