Formule avec trois/quatre conditions ?

Bonjour,

Je suis en train de faire un fichier Excel pour voir l’évolution du chiffre d'affaires sur 3 années et par la suite sur 4 année.

Du coup j'ai un fichier avec en colonne A les entreprises ; B le CA 2017 ; C CA 2018 ; D CA 2019 ; E CA 2020 ; en G L'évolution du CA.

Je voudrai faire une formule dans G avec trois conditions pour l’instant et dans le future rajouter une quatrième. Mes conditions sont les suivantes :

- SI le CA 2019>0 alors (CA2019-CA2017)/CA2019

- Si le CA2017 est vide = 0 faire la formule suivante (CA2019-CA2018)/CA2019

- et si le CA2019 = 0 alors apparaît "Nouveau CA"

Je voulais faire la fonction SI mais je n'arrive à mettre les trois conditions dans une même formule, cellule...

Je vous joint mon fichier teste pour avoir un petit visu.

Si vous avez une idée de comment faire je vous serais très reconnaissante car la je bloque alors que c'est peu être tout simple...

Avec mes remerciements

Bien à vous

Diane

7doc-test.xlsx (9.90 Ko)

Bonjour Dianec et

Voici la formule à tester

=SI(D2="";"Nouveau CA";SI(B2<>"";(D2-B2)/D2;SI(C2<>"";(D2-C2)/D2)))

@+

Merci beaucoup BrunoM45 !

Ça marche ! c'est si simple je me sens bête ....

Rechercher des sujets similaires à "formule trois quatre conditions"