Fonction date

Bonjour,

je recherche une solution pour evtiter de saisir la date et l'heure par exemple je voudrais tester une cellule si elle est egale à "Date_H" dans la cellule suivante se met le date en cours et dans la cellule suivante je met l'heure en cours cela marche avec l'exemple suivant:

=SI(D23="Date_H";MAINTENANT();"") Format cellule date

=SI(D23="Date_H";MAINTENANT();"") Format cellule Heure

D23="Date_H"

Cela fonctionne .

Le probleme c'est que c'est un affichage dynamique est cela modiftoutes les cellules avec la meme date et la meme heure.

12/04/2008 16:49:07 Date_H

12/04/2008 16:49:07 Date_H

12/04/2008 16:49:07 Date_H

Ce que que je recherche c' est :

12/04/2008 16:49:07 Date_H

12/04/2008 18:12:04 Date_H

13/05/2008 08:23:14 Date_H

Voila !

Merci

A+ Michel

hello

est-ce ce que ty cherches ?

Pour insérer une date ou heure statique

Date en cours Sélectionnez une cellule et appuyez sur CTRL+;

Heure en cours Sélectionnez une cellule et appuyez sur CTRL+MAJ+;

Date et heure en cours Sélectionnez une cellule et appuyez sur CTRL+; ensuite ESPACE puis CTRL+MAJ+;

19bl-charge.zip (7.15 Ko)
jmd a écrit :

hello

est-ce ce que ty cherches ?

Pour insérer une date ou heure statique

Date en cours Sélectionnez une cellule et appuyez sur CTRL+;

Heure en cours Sélectionnez une cellule et appuyez sur CTRL+MAJ+;

Date et heure en cours Sélectionnez une cellule et appuyez sur CTRL+; ensuite ESPACE puis CTRL+MAJ+;

Non cela ne reponds pas mon besoin je voudrais tester par exemple D23="Date_H"

pour avoir la date l'heure statique

Bonjour,salut jmd,

Si j'ai compris le problème, il faudrait que la fonction MAINTENANT() ne se réactualise pas à chaque validation d'une cellule quelconque dans la feuille.

Essaie le principe suivant :

Menu Outils / Options / Calcul / cocher "Itérations".

Saisir en A1 (par exemple) : =SI(A1=0;MAINTENANT();A1)

La date et l'heure en A1 restent figées.

Si tu ne parviens pas à appliquer ce principe à ton cas, mets un petit exemple en pièce jointe, on essaiera de t'aider.

Bonjour,

Si j'ai bien compris,avec une petite macro.

Tape une lettre dans la colonne A

https://www.excel-pratique.com/~files/doc/Dateheure.xls

A +

henri a écrit :

Bonjour,

Si j'ai bien compris,avec une petite macro.

Tape une lettre dans la colonne A

https://www.excel-pratique.com/~files/doc/Dateheure.xls

A +

c'est cela . Merci.

ReMerci

A+

Rechercher des sujets similaires à "fonction date"