Date Max avec condition

Bonjour,

J'ai fais des recherches sur le forum et ai trouvé beaucoup de réponses mais quand à les appliquer c'est une autre affaire !

J'ai un tableau avec deux colonnes : "ID et Date"

Je souhaiterai obtenir la date la plus récente pour un ID donné.

J'ai tenté avec Mina et Maxa, j'ai essayé avec RechercheV combinant Mina et Maxa, j'ai essayé avec Grand.Valeur et Petite.Valeur hélas, je ne m'en sors pas .

Voici mon test en pièce jointe

Toute aide sera utile et un grand merci par avance.

bfromb

6date-max.zip (10.55 Ko)

Bonjour,

il y a quelque chose qui m'interpelle : la structure de ton tableau et du résultat que tu veux obtenir.

Par exemple, pour 17 :

Tu veux avoir 3 fois la même valeur de date ?

Est-ce que c'est vraiment nécessaire ?

Le mieux ne serait pas d'avoir qu'une fois la valeur 17 et le MAX correspondant ?

Ce ne sont que de simples questions, j'essaie de comprendre l'utilité

Bonjour Yoyo0100,

En fait dans mon fichier, la colonne C est la valeur recherchée (Souhaité par rapport à la colonne B)

ID Date Valeur recherchée

85 07/09/2012 07/09/2012

17 15/10/1977 12/10/1979

17 30/09/1978 12/10/1979

17 12/10/1979 12/10/1979

18 05/01/1981 20/11/1985

18 13/02/1982 20/11/1985

18 20/11/1985 20/11/1985

19 17/10/1986 30/03/1993

19 30/03/1993 30/03/1993

Après que la valeur apparaisse sur les trois ligne ou une seule fois ce n'est pas très important car je pourrais supprimer les doublons. Mais je suis preneur de toute solution qui me permette de bien identifier la date la plus récente pour chacun des ID.

Merci déjà de ton retour

Bonjour,

Je me suis également intéressé à ce problème et ai trouvé une solution par macro.

Dans le fichier ci-joint, à chaque nouvelle sélection, les colonnes C et D sont réactualisées. Faire un essai par exemple en effaçant les données de ces colonnes C et D ou en modifiant les données des colonnes A et B.

Toutes sortes d'améliorations sont possibles.

Amicalement.

10date-max-v1.zip (29.31 Ko)

Bonjour Yvouille,

Effectivement ça fait exactement ce que je recherche et je t'en remercie.

Je comprends pas bien le VBA Excel mais faudra que je m'y mette, un jour peut être

Je croyais naïvement que ça pouvait être trouvé par une formule

Chapeau bas !

Merci beaucoup

Bonjour bfromb, le forum

Essayez la formule suivante à coller en D2 et étendre vers le bas tant que nécessaire

=SI(ESTNUM(EQUIV(MAX.SI($C$2:$C$10;$A$2:$A$10;$A2);$D$1:D1;0));"";MAX.SI($C$2:$C$10;$A$2:$A$10;$A2))

En fait j'ai mal lu et la valeur cherchée étant en colonne B la formule devient:

=SI(ESTNUM(EQUIV(MAX.SI($B$2:$B$10;$A$2:$A$10;$A2);$C$1:C1;0));"";MAX.SI($B$2:$B$10;$A$2:$A$10;$A2))

Bonjour,

Une solution avec un tableau croisé dynamique (TCD) ?

Cdlt.

5date-max.xlsx (14.76 Ko)
iso4219

Re,

Merci de ton retour en MP ?.

Pense à clore le sujet et à remercier les autres intervenants.

Cdlt.

Rechercher des sujets similaires à "date max condition"