Convertir heure

bonjour,

sur un tableau, je travail en centième d'heure

Exemple: 5,6

en calcul,ça me donne 5H et 36 minutes

Je voudrais faire apparaître une cellule avec une formule me transformant mes 5.6 en 5H36

Merci

Bonjour,

Si A1 : 5,6

tu mets en B1 --> 5,6/24 en prenant soin de formatter ta cellule en Heure ou au format heure personnalisé --> [hh]:mm

Amicalement

Dan

merci Dan pour ta réponse.

J'ai une autre question. Le même problème mais en heure négative.

Cordialement

Bonjour,

Le mieux serait que tu donnes un exemple.

Ce que tu peux déjà faire entre-temps pour les heures négatives, c'est de cocher le calendrier 1904 dans menu/outils/options/calcul.

A utiliser avec prudence surtout si tu as des dates dans ta feuille.

A te lire

Dan

1stock.zip (6.16 Ko)

bonjour

Pas bon pour le calcul, mais bon pour l'affichage...

1) Comme dit par Dan, cocher calendrier depuis 1904

2) Format de cellule [h]:mm

3) Nombres en colonnes A, heures en colonne B

4) Formule en B:

=SI(A2<0;-(PLAFOND(ABS(A2)*"1:";1/60/24/2));PLAFOND(A2*"1:";1/60/24/2))

Pas terrible, mais pas mieux pour l'instant

Cordialement

bonjour Dan,

J'ai un tableau avec un planning d'heures mensuel et annuel. Sur ce tableau, j'ai un compteur qui m'indique en temps réel les heures effectuées ( + ) ou les heures que je dois ( - ) . Le problème est que ces heures sont en centième d'heure . j'ai mis en place ta formule et ça foctionne pour les heures + mais pas pour les heures négatives.

Merci pour ta réponse.

re,

as-tu coché le calendrier 1904 comme je te l'iai dit avant ?

A te lire

Dan

Re,

Merci Dan et Amadéus.

ça fonctionne en + et en -.

A+ et encore merci

Rechercher des sujets similaires à "convertir heure"