Compteur de bonnes réponses

Bonjour a tous,

je travail dans la finance et je donne également des cours et des formations dans ce domaine. J'ai créé une petite application excel pour mes élèves qui choisit aléatoirement une question dans une base de données, la personne réponds et voit si sa réponse est bonne ou mauvaise. Si la réponse est mauvaise, la personne peut (enfin pourra, je n'ai pas encore créé la macro) visualiser la réponse ainsi qu'un petit commentaire explicatif.

J'aimerai insérer dans cette application une barre graphique montrant la progression du quizz... (donc ça je pense que ça ira, il faut que je cherche un peu...)

Par contre, j'aimerai insérer un compteur de bonne réponse, mais je ne vois pas du tout comment m'y prendre...

Si quelqu'un a une réponse a m'apporter...

Merci d'avance,

Cordialement

Bonsoir,

Comment qualifies-tu les bonnes réponses. Par une donnée dans une colonne ??

A te lire

Dan

Ben justement, je ne sais pas trop comment faire...

Bonsoir,

Et si tu envoyais une maquette de ce que tu veux, ça permettrait de nous éclairer...

Elbie

ok, je ferais ça demain, la je m'en vais,

Merci pour vos réponses,

a demain,

Souri84

je fais remonter le topic, il était dans le fin fond du forum, heureusement que je l'ai retrouvé, il était ente 2 fagots, je vous raconte pas....

Bon sinon, je n'ai toujours pas réussi à faire ce maudit compteur de bonne réponse... j'avais tenté de créer une macro:

sur une autre feuille du classeur, descendre d'une ligne, marquer 1 dans la colonne A (Y); et si(cellule="BONNE REPONSE"; 1;0) dans la colonne B (X).

Ensuite sur l'interface du questionnaire, on avait "vous avez X sur Y". Cette macro fonctionne très bien si je fais macro => executer la macro. Mais quand je mets le code dans un bouton, ça me mets la boite de dialogue de débogage....

Avez vous une autre soluce?

Bonsoir,

un petit fichier joint nous permettrait d'avoir une idé plus claire du travail à réaliser.

Cordialement.

Bonjour,

un exemple de ton fichier nous aideraient plus facilement.

As tu essayé =SOMME.SI(A1:D12;"X")

ou =NB.SI(...

A +

j'ai oublié de dire: renommer l'onglet "interface du questionnaire" par "interface" sinon le bouton du sommaire ne fonctionne pas....

J'avais rajouté questionnaire pour que ce soit plus clair pour vous, mais j'ai oublié de modifier la macro... donc pour un souci de simplicité, renommer l'onglet "interface du questionnaire" par "interface"

Bonsoir,

le lien que tu nous met ne reprend ta demande.

A +

Bonsoir,

étant un peux en froid avec VBA,la seul remarque que je peux faire en regardant le code, est que la feuille "interface" n'existe pas !!!!!!!!!!!!!!!

A +

henri a écrit :

Bonsoir,

étant un peux en froid avec VBA,la seul remarque que je peux faire en regardant le code, est que la feuille "interface" n'existe pas !!!!!!!!!!!!!!!

A +

C ce que j'ai dit un peu plus haut... il faut renommer la feuille "interface questionnaire" par "interface"

Rechercher des sujets similaires à "compteur bonnes reponses"