Compter le nombre de différentes occurences dans une colonne (FACILE)

Bonjour,

Je cherche la fonction qui pourrait me permettre de calculer le nombre d' occurences différentes dans un colonne,

Sur mon exemple,

Je veux savoir combien de noms différents apparaissent dans la colonne CA.

Ici je veux comme réponse : 3

EAZY PEAZY pour vous je suppose !!

Seulement, compliqué à expliquer dans une barre google, il doit y avoir une fonction speciale que je ne connais pas ou que j'ai oublié.

Merci d'avance,

Amour sur vous

capture d ecran 2020 02 17 a 19 21 20

Salut JimmyDean,

facile, facile... pour les pros de la formule, oui...

En chipotant sur Gooogle, j'ai trouvé quelque chose en deux étapes :

- une première formule pour trouver le n° de la dernière ligne de ta colonne "CA" : ici, j'ai mis [B:B], colonne réelle ;

=MAX(SIERREUR(EQUIV("zzz";B:B;1);0))

- une deuxième pour ta demande qui reprend le résultat de la première : tu auras compris qu'ici, j'ai mis ma 1ère formule en [A14] !

=SOMMEPROD(1/NB.SI(INDIRECT("B2:B" & A14);INDIRECT("B2:B" & A14)))

Á toi d'adapter tout ça... ou d'attendre le passage d'un pro de la formule !

A+

Bonsoir,

Un autre essai Colonne B = CA

=SOMMEPROD(1/NB.SI(B2:B10;B2:B10))

Slts

bonsoir

une petite contribution

24jimmydean.xlsx (8.95 Ko)

cordialement

Bonjour à tous

Ma petite contribution également.

Cdt

Henri

Merci à tous,

Amour sur vous

Mais je ne trouve pas encore mon bonheur,

PRIMO, j'aimerais ne pas avoir de macros,

SEGONDO, Je cherche simplement a avoir une formule qui va me dire :

Garrigou 1

Le coant 2

Ribaud 4

Je pensais, je vous avoue, qu'il existait une formule.

Je vais pinailler je sens !!

HELP

Re

Un essais avec formule

Slts

Bonsoir @ tous,

Merci à tous,

Amour sur vous

Mais je ne trouve pas encore mon bonheur,

PRIMO, j'aimerais ne pas avoir de macros,

SEGONDO, Je cherche simplement a avoir une formule qui va me dire :

Garrigou 1

Le coant 2

Ribaud 4

Je pensais, je vous avoue, qu'il existait une formule.

Je vais pinailler je sens !!

HELP

C'était pas la question dans ton premier message, d'où nos chers amis t'ont donné plusieurs formules pour que tu aies l'embarras du choix.

Un fichier exemple avec les résultats escomptés aurait dû être le bienvenu pour avoir des réponses concises.

Cordialement

bonjour

re contribution avec tout les cas possibles

17jimmydean22.xlsx (12.62 Ko)

cordialement

Bonjour,

Simplement insérer un TCD ...

Bonjour à tous et Merci pour vos retours,

Suite à différents essais je ne trouve toujours pas mon bonheur, et je pense que c'est aussi parce que je me suis mal exprimé.

Je repars donc à ZERO.

Je voudrais, compter le nombre de Personnes présentes le 17/02/20 et le 18/02/20 à LORIENT et RENNES

Le 17, 2 personnes à Lorient et 1 à Rennes

Le 18, 1 à Lorient et 1 à Rennes

Comme sur le visuel,

Pour info, le premier tableau est ma base brut, à partir de quoi je veux tirer des statistiques etc etc...

Merci, et désolé pour mes précédents postes ou j'avais mal formulé ma question, je crois même que moi-même je m'y etais perdu.

capture d ecran 2020 02 25 a 14 57 06

Bonjour,

Dans un Forum Excel .... une assez bonne idée ... joindre un Fichier Excel ... ( FACILE )

Une image est un objet inerte ... qui ne sert ... à rien ...

Rechercher des sujets similaires à "compter nombre differentes occurences colonne facile"