Comment sommer les valeurs d'une plage avec condition sur une autre plage?

Comment sommer les valeurs d'une colonne respectant une condition que l'on doit aller chercher dans une autre plage?

Ex: J'ai une première plage de deux colonnes: une colonne "Personnes" et une autre colonne "Salaire"

J'ai une autre plage de deux colonnes m'indiquant dans quelle ville habite chaque personne.

Il est nécessaire que ces deux plages soient séparées

Je cherche la formule qui va me donner la somme des salaires des parisiens...

J'ai fait un petit exemple dans le fichier joint, avec un exemple de tentative qui ne marche pas (j'essaye de combiner un recherchev avec une formule matricielle...)

Merci pour vos lumières!

Pruvieros

Bonsoir le forum,

H2 :

[b]=SOMMEPROD(($B$2:$B$9=G2)*($E$2:$E$9))

[/b]A tirer vers le bas.

Re,

Ou :

[b][b]=SOMME.SI.ENS(E:E;B:B;G2)

[/b][/b]

Merci beaucoup pour cette réponse.

Je réalise que j'ai trop simplifié le problème par rapport à ma situation.

Voici un deuxième fichier dans lequel:

  • il n'y a pas autant de lignes dans une plage que dans l'autre
  • Les plages ne sont pas côte à côte (dans ma situation réelle, elles sont sur deux feuilles séparées)

Le problème reste le même: comment sommer les salaires connus des parisiens (puis des marseillais, puis des lyonnais)

Encore une fois, merci par avance pour votre aide!

Pruvieros

Merci encore, mais je n'ai pas le contrôle de l'ordre dans lequel les gens apparaissent dans la plage roses...

Ex:

Re,

F11 : =RECHERCHEV(D11;$A$2:$B$9;2;0)

sommeprod 3

bonsoir

Ok mais si les noms ne sont plus au droit des villes ???????????????????????????????

un essai

3pruvieros.xlsx (10.41 Ko)

cordialement

Dupont est le seul parisien (dans le fichier v3)

Et effectivement, les noms ne sont plus au droit des villes.

Où réside donc Jean ?

Pardon, effectivement, Jean réside à Paris!

Oups! Pardon... Il réside bien à Paris.

Mais je ne comprends pas ta formule, car en colonne F il n'y a pas de données... As-tu déplacé une plage?

Re,

F11 : =RECHERCHEV(D11;$A$2:$B$9;2;0)

Rechercher des sujets similaires à "comment sommer valeurs plage condition"