Calcul Taux d'échec sur plage par mois

Bonjour,

J'aimerai trouver une formule qui me calcule par mois un taux : Nombre de pourcentage <100% du mois / Nombre de pourcentage total du mois

Pour arriver

à ce résultat, je copie le mois concerné et je fais un tri croissant.

Mais j'aimerai arriver à ce résultat avec un calcul recherchant directement dans un plage où les valeurs sont mélangées, en l'occurrence la plage se trouvant dans la BASE.

Merci d'avance

3taux-d-echec.xlsx (14.98 Ko)

Salut est-ce possible pour toi d'utiliser un format de Date Excel dans la colonne A ?

Si oui le tri par mois sera plus aisé.

Sinon je te propose un solution en PJ.

3taux-d-echec.xlsx (15.57 Ko)

Girodo,

Bonjour

Mise sous forme de tableau structuré nommé Base de la source puis 2 solutions

  • soit TCD avec segment pour choisir la période
  • soit Formule avec saisie de la période
3taux-d-echec2.xlsx (23.84 Ko)

Edit :

bonjour Girodo, je n'avais pas raffraichi et vu ta réponse

bonjour xorsankukai : on a sensiblement la même formule mais le tableau permet quelle évolue en même temps que les données...

Bonjour EES_VM, Girodo, 78chris,le forum,

Un essai:

=NB.SI.ENS(BASE!$A$2:$A$348;'Exemple Resultat attendu'!$D$24;BASE!$B$2:$B$348;"<100%")/NB.SI(BASE!$A$2:$A$348;'Exemple Resultat attendu'!$D$24)
1taux-d-echec.xlsx (17.16 Ko)

Cordialement,

Salut est-ce possible pour toi d'utiliser un format de Date Excel dans la colonne A ?

Si oui le tri par mois sera plus aisé.

Sinon je te propose un solution en PJ.

3taux-d-echec.xlsx (15.57 Ko)

Girodo,

Oui j'ai une colonne avec les dates précises. Après ce que tu m'as répondu me convient très bien. Merci

Salut est-ce possible pour toi d'utiliser un format de Date Excel dans la colonne A ?

Si oui le tri par mois sera plus aisé.

Sinon je te propose un solution en PJ.

3taux-d-echec.xlsx (15.57 Ko)

Girodo,

J'ai oublié un paramètre... il y a 2 cas à prendre en compte.

Est-ce possible de m'aider sur la formule qui a été faite sur l'onglet BASE ?

Merci d'avance

1taux-d-echec.xlsx (17.05 Ko)

Bonjour tout le monde,

Un essai....

En H2:

=NB.SI.ENS(A:A;G2;B:B;"NEGO";C:C;"<100%")/NB.SI(A:A;G2)

En I2:

=NB.SI.ENS(A:A;G2;B:B;"TVX";C:C;"<100%")/NB.SI(A:A;G2)

Fonction NB.SI.ENS

Cordialement,

Parfait xorsankukai !

Merci

Rechercher des sujets similaires à "calcul taux echec plage mois"