Calcul sur plusieurs feuilles

Bonjour à toutes et à tous,

Une petite question.

Nous avons un classeur avec un certain nombre de feuille, par exemple 10, mais il peut y en avoir 25 ou 30 et nous souhaitons avoir une feuille de synthèse qui va calculer une somme conditionnelle.

Actuellement, nous avons une formule du genre (exemple pour 4 feuilles, mais imaginez pour 20 ou 25 feuilles):

=SOMME.SI('Feuille A'!A3:A7;A2;'Feuille A'!B3:B7)+SOMME.SI('Feuille B'!A3:A7;A2;'Feuille B'!B3:B7)+SOMME.SI('Feuille C'!A3:A7;A2;'Feuille C'!B3:B7)+SOMME.SI('Feuille D'!A3:A7;A2;'Feuille D'!B3:B7)

Nous avons tenté cela

=SOMME.SI('Feuille A:Feuille D'!A3:A7;"A";'Feuille A:Feuille D'!B3:B7)

Malheureusement, cela ne fonctionne pas.

Avez-vous une idée pour réduire cette formule ?

3exemple.xlsx (12.33 Ko)

Bonjour

Je doute que l'exemple soit représentatif. S'il l'est une simple somme 3D suffit.

Sinon fournir un fichier représentatif...

Oui, le fichier est représentatif.

Pourriez-vous me montrer un exemple de somme 3D que vous préconisez ?

Merci

Bonjour, Bonjour Chris,

Avec des fonctions indirect :

capture
En C3 =SOMME.SI(INDIRECT("'"&C$2&"'!$A$3:$A$37");$A3;INDIRECT("'"&C$2&"'!$B$3:$B$37"))

Bonjour

3 solutions ci-joint

  • SOMME 3D si positions immuable
  • SOMME conditionnelle avec liste des onglets
  • POWERQUERY
Rechercher des sujets similaires à "calcul feuilles"