Calcul de primes avec tranches

Bonjour

Pourriez vous me dépanner svp sur une formule de calcul de prime que je vais tenter d'expliquer clairement :

Règles de la prime :

150 clients = 500€

+ par clients supplémentaires suivant tranches ci-dessous :

Tranche 1 : de 151 à 175 = 10€ par client

Tranche 2 : de 176 à 199 = 15€ par client

Tranche 3 : >= 200 = 20€ par client

Exemples concrets :

168 clients = 500€ + (18x10 de la tranche 1) = 680€

210 clients = 500€ + (25x10 de la tranche 1) + (24 x 15 de la tranche 2) + (11 x 20 de la tranche 3) = 1330€

Merci par avance

Bonjour,

à tester,

=SI(A1<=150;500;500+(A1-150)*(INDEX({10;15;20};EQUIV(A1;{151;176;200}))))

Merci.

Je ne connais pas la fonction INDEX/EQUIV, il me faut faire un tableau à coté c'est cela ?

NB : j'ai modifié le signe au début de votre formule, c'est > car si < 150 c'est zéro prime.

bonjour

un essai /contribution

88astrgale.xlsx (8.79 Ko)

cordialement

Bonjour,

Merci beaucoup, ça marche très bien et je n'aurais absolument pas été capable de faire une telle formule

Bonne journée !

Rechercher des sujets similaires à "calcul primes tranches"