Arrondi et cumul : fonction matricielle

Bonjour,

Mon problème est simple.

J'ai une colonne avec des valeurs entières et/ou des valeurs non entières.

Je souhaite arrondir toutes les valeurs, j'utilise donc la formule arrondi qui me donne le résultat souhaité.

Le problème est que je veux faire le cumul des arrondis :

Le hic c'est de le faire sans colonne intermédiaire.

Je souhaite savoir s'il existe (sans vba, sans morefunction) une formule matricielle qui me renverrait la matrice des valeurs. En gros dans le fichier joint, je voudrais une formule qui marche de la manière suivante :

Je selectionne F2:F6 je tappe = et je rentre ma formule matricielle

J'ai tout essayé, sous.total combiné avec décaller mais ne fonctionne pas avec arrondi : car ça fait l'arrondi de la somme des cellules et non la somme des arrondis.

Je serais curieux d'avoir vos réponses merci les amis.

Bonjour,

Je ne vois pas pourquoi une formule matricielle

Sélectionner F1:F6 tapez la formule =ARRONDI(A2;)+F1 et valider par Ctrl+Enter

Attention F1 doit être vide

bonjour keta ;meilleurs voeux

un debut de piste ; je n'ai pas trop planché (timing)

'=SOMME(PLAFOND(A2:A6;1))

a valider matriciel

je crois qu'en remplacant A6 par A2 avec $ pour figer ;puis incrementer ....... ,ça doit

cordialement

15keta.zip (7.25 Ko)

je viens de modifier

Slt tulipe, bonne année meilleur voeux

Malheureusement ta formule ne fonctionne pas tout à fait comme je le voudrais.

Enfait, il me faut une formule qui me renvoie une matrice des valeurs directement et non ligne par ligne.

Je selectionne toute la plage F2:F6 et il faut une formule matricielle ensuite.

De cette manière je pourrais utiliser cette matrice.

j'ai passé la nuit à essayer de trouver une solution, j'ai presque tout tenter , et la j'ai les yeux qui piquent sévèrent

cdt


Bonjour Robjam :

Il me faut une matricielle pour éviter une colonne intermédiaire tout simplement.

Merci pour ta réponse, comme Tulipe, elle ne me permet pas de travailler sur ces valeurs sans colonne intermédiaire.

Ce n'est pas pour ça mais imaginons que je veuille classer ces valeurs , je ne peux pas utiliser petite.valeur(ta_formule,ligne(A1:Axxx) : il faut une colonne intermédiaire

merci quand même et bonne année à toi aussi

cdt

Bonjour,

Ce que tu souhaites faire n'est pas simple. Si tu dois réutiliser cette formule dans d'autres formules, le résultat sera imbuvable...

=PROBABILITE(LIGNE(A2:A6);ARRONDI(A2:A6)/SOMME(ARRONDI(A2:A6));;LIGNE(A2:A6))*SOMME(ARRONDI(A2:A6))

Matricielle bien sûr.

Ne fonctionne qu'avec des nombres positifs.

A+

Merci beaucoup Oooiste

Ca marche du tonnerre .

Je ne connaissais pas du tout cette utilisation de probabilté ! Bien vu!!!

Merci également aux autres pour leur réponse.

Bonne journée à vous

Thxx

Rechercher des sujets similaires à "arrondi cumul fonction matricielle"