Adresse cellule

Bonjour,

Qui peut me trouver comment trouver l'adresse de la dernière cellule non vide d'une colonne, mais en commençant à a5 par exemple et me renvoyer l'adresse dans une cellule

Merci

Bonjour,

une solution via une fonction personnalisée à insérer dans un module

Function dcu(c As Range) As String
    dcu = Cells(Rows.Count, c.Column).End(xlUp).Address
End Function

appeler la fonction

=dcu(c) où C est soit une colonne soit une cellule de la colonne dont il faut rechercher la dernière valeur.

exemple d'utilisation :

=dcu(A:A) ou =dcu(B6)

Oh là, peux m'expliquer ta fonction .


Je voudrais que le résultat de l'adresse s'affiche dans une cellule.

@+

Hello!

Pour éviter les $

Sub Adresse_cellule()
Dim adresse As String
Dim i

'Tu prend la cellule A5 et tu vas jusqu'à la dernière ligne non vide et tu prends l'adresse de cette cellule
adresse = Range("A5").End(xlDown).Address

'Tu splite ta variable pour enlever les $
i = Split(adresse, "$")

'Tu recrée ta variable adresse avec les deux valeurs (colonne et ligne) splittées
adresse = i(1) & i(2)

'Afficher l'adresse dans une msgbox
MsgBox (adresse)

End Sub

Après tu peux utiliser la variable adresse pour l'assigner à la valeur de la cellule que tu veux

re bonjour,

voir exemple en pièce jointe. utilisation de la fonction en ligne 1

7bouddha62.xlsm (13.89 Ko)

Merci j'essaye de suite

Merci


Ok cela fonctionne, mais alors comment puis je intégrer dans une fonction type: =SOMME.SI(Saisie!Plage A 5 : dcu(a:a) ;$A$5&C$4;Saisie!$F$3:$F$5000)?????

re bonjour,

essaie ainsi

=SOMME.SI(indirect("Saisie!A5:" & dcu(a:a)) ;$A$5&C$4;Saisie!$F$3:$F$5000)

Merci à toi , cela fonctionne correctement

@+

Rechercher des sujets similaires à "adresse"