Addition sous conditions VBA

bonjour le forum, bonjour à tous,

je cherche un code VBA pour trouver en colonne N, sur la même ligne que le numéro de poste 1 en colonne H , la somme des quantités qui se trouvent en colonne K pour un même lot en colonne C.

exemple du résultat attendu sur le fichier joint très allégé (la feuille fait 15000 lignes et devrait être à +/- 25000 fin d'année).

merci d'avance.

Pedro.

4prod.xlsx (19.29 Ko)

Bonjour,

Une proposition sans VBA ...

=SI(H4=1;SOMME.SI($C$4:$C$100;C4;$K$4:$K$100);"")

Cordialement.

Bonjour à tous,

Le code convertit les données des colonnes A et C au format chiffres ... puis, trie sur la colonne C et, enfin, additionne les valeurs demandées.

Un essai ...

ric

2prod-v2.xlsm (24.78 Ko)

bonjour @Ric,

ça bloque quand il y a plus de données à la ligne 255 sans raison apparente, bizarre!

Pedro.

1prod-v2.xlsm (68.85 Ko)

Bonjour,

Excuse-moi, j'ai sous-estimé l'utilisation des types de variables.

ric

2prod-v3.xlsm (64.17 Ko)

Il me faudra du temps pour tout intégrer...

je n'y ai pas pensé alors même que j'ai bossé les variables et les conditions (cours vba sur le site) il y a à peine 1 semaine).

merci beaucoup Monsieur @Ric.

Pedro.

Rechercher des sujets similaires à "addition conditions vba"