Trouver un mot et y associer un code

Y compris Power BI, Power Query et toute autre question en lien avec Excel
v
val33
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 5 septembre 2018
Version d'Excel : 2010

Message par val33 » 5 septembre 2018, 15:12

Bonjour,
Je souhaiterais avoir une formule ou VBA me permettant de trouver un mot, par exemple "TOTO" en feuill1 et d'y associer un nombre à partir d'une base de données en feuill2. Le résultat serait en B1 en feuill1.
J'espère que c'est à peu près clair ...
Merci beaucoup par avance
TEST.xlsx
(8.85 Kio) Téléchargé 9 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'361
Appréciations reçues : 237
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 5 septembre 2018, 15:29

Bonjour le forum,

=SI(NB.SI(A1;"*TOTO*")=1;RECHERCHEV("TOTO";Feuil2!A:B;2;0);"")
v
val33
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 5 septembre 2018
Version d'Excel : 2010

Message par val33 » 5 septembre 2018, 15:30

Merci beaucoup, ça fonctionne !!!
v
val33
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 5 septembre 2018
Version d'Excel : 2010

Message par val33 » 5 septembre 2018, 15:57

ça fonctionne mais j'essaie d'appliquer cette formule sur une base de données beaucoup plus importante. N'y a t-il pas plus simple ?
Merci
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'698
Appréciations reçues : 646
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 6 septembre 2018, 00:22

Bonjour val,

:bv:
 
tu a écrit :j'essaie d'appliquer cette formule sur une base de données beaucoup plus importante. N'y a-t-il pas plus simple ?
je te retourne ton fichier modifié :
TEST.xlsm
(16.43 Kio) Téléchargé 12 fois
Ctrl e ➯ travail effectué !  :)

Alt F11 pour voir le code VBA, puis revenir sur Excel

⚠  si ton vrai fichier est un fichier .xlsx : il doit d'abord être converti en .xlsm pour pouvoir y mettre du code VBA ; ensuite, tu devras insérer un nouveau module, et y copier/coller le code VBA de ma macro ; de retour sur Excel, pour lancer la macro : via Alt F8, ou via un raccourci clavier (à ajouter), ou via un bouton (à ajouter).

si besoin, tu peux demander une adaptation.
merci de me dire si ça te convient.

dhany  Image
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'665
Appréciations reçues : 24
Inscrit le : 14 novembre 2012
Version d'Excel : 2016 FR

Message par R@chid » 6 septembre 2018, 02:11

Bonsoir @ tous,
:bv:
mbbp a écrit :
5 septembre 2018, 15:29
Bonjour le forum,

=SI(NB.SI(A1;"*TOTO*")=1;RECHERCHEV("TOTO";Feuil2!A:B;2;0);"")
c'est pas la bonne formule, il faut impérativement passer par une formule matricielle.
Voir pièce jointe.
val33.xlsx
(9.69 Kio) Téléchargé 13 fois
Cordialement
1 membre du forum aime ce message.
"Donnez moi un point d'appui et je soulèverai le monde"
v
val33
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 5 septembre 2018
Version d'Excel : 2010

Message par val33 » 6 septembre 2018, 11:08

Bonjour Dhany,
C'est exactement ce que je voulais !!!
Dernière chose, si c'est possible, dans mon tableau la colonne A de mon fichier "Test" correspond à la colonne B et la colonne B du fichier "Test" à la colonne F.
Du coup, je ne sais pas comment modifier la macro...
Encore merci beaucoup !!!
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'698
Appréciations reçues : 646
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 6 septembre 2018, 11:12

c'que tu as écrit est pour Feuil1 ou Feuil2 ?

dhany
v
val33
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 5 septembre 2018
Version d'Excel : 2010

Message par val33 » 6 septembre 2018, 11:16

Oui, pardon. C'est pour la feuill1
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'698
Appréciations reçues : 646
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 6 septembre 2018, 11:20

alors ok, j'vais faire ça de suite ; patiente juste un moment.

dhany
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message