Somme cellule avec chiffre melanger texte

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
t
thomas78320
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 12 octobre 2016
Version d'Excel : 2010

Message par thomas78320 » 12 octobre 2016, 11:00

Bonjour,

j'ai un soucis sur un fichier sur lequel je travail.

Je dois faire la somme d'une colonne avec des cellules comportant texte + valeur.

exemple :
A1: texte 2
A2: texte 1
A3: texte 2
A4: somme 5

j'ai déjà fais des recherches sur le forum et trouvé la formule SOMME(STXT(N402:N415;CHERCHE(" ";N402:N415;1)+1;5)*1) le problème c'est que la formule ne marche quand une des cellules est vide, j'ai une erreur de valeur.

j'arrive pas à trouver de solution , :help:

Ci-joint : exemple

Merci par avance

cordialement,
un jeune en voie d'apprentissage
exemple.xlsx
(10.06 Kio) Téléchargé 31 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 12 octobre 2016, 13:01

Bonjour le forum,

Sélectionner : D11:D14
Rechercher et remplacer (voir image jointe).

D15 :
=SOMMEPROD(--(DROITE(D11:D14;NBCAR(D11:D14)-CHERCHE(" ";D11:D14;1))))
Remplacer.png
Remplacer.png (5.33 Kio) Vu 725 fois
t
thomas78320
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 12 octobre 2016
Version d'Excel : 2010

Message par thomas78320 » 12 octobre 2016, 13:24

Je ne peux pas rajouter du texte dans les colonnes , le fichier serait trop lourd pour l'instant j'essaye avec cette formule :

SOMME(STXT(N402&":"&"N"&402+NB.SI(N403:N415;"*");CHERCHE(" ";N402&":"&"N"&402+NB.SI(N402:N415;"*")-1;1)+1;5)*1)

J'ai décomposé la formule et c'est la fonction somme qui ne marche pas
Modifié en dernier par thomas78320 le 12 octobre 2016, 14:25, modifié 1 fois.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 12 octobre 2016, 13:37

Pour ne pas voir "texte 0" : une simple MFC
Texte Somme.png
Texte Somme.png (8.6 Kio) Vu 720 fois
t
thomas78320
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 12 octobre 2016
Version d'Excel : 2010

Message par thomas78320 » 12 octobre 2016, 13:45

Salut mbbp,

Peux-tu envoyer le fichier je ne sais pas comment tu as fais :)

Merci you are best :D
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 12 octobre 2016, 13:57

Utilisation de la formule déjà proposée dans mon précédent post.
Pour D8 :
=SOMMEPROD(--(DROITE(D5:D7;NBCAR(D5:D7)-CHERCHE(" ";D5:D7;1))))
et MFC :
=$D1="texte 0"
S'applique à : =$D:$D
t
thomas78320
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 12 octobre 2016
Version d'Excel : 2010

Message par thomas78320 » 12 octobre 2016, 14:08

je viens d'essayer sa ne marche toujours pas, erreur de valeur :oops:

merci pour ton aide
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message