Somme cellule avec chiffre melanger texte

Bonjour,

j'ai un soucis sur un fichier sur lequel je travail.

Je dois faire la somme d'une colonne avec des cellules comportant texte + valeur.

exemple :

A1: texte 2

A2: texte 1

A3: texte 2

A4: somme 5

j'ai déjà fais des recherches sur le forum et trouvé la formule SOMME(STXT(N402:N415;CHERCHE(" ";N402:N415;1)+1;5)*1) le problème c'est que la formule ne marche quand une des cellules est vide, j'ai une erreur de valeur.

j'arrive pas à trouver de solution ,

Ci-joint : exemple

Merci par avance

cordialement,

un jeune en voie d'apprentissage

32exemple.xlsx (10.06 Ko)

Bonjour le forum,

Sélectionner : D11:D14

Rechercher et remplacer (voir image jointe).

D15 :

=SOMMEPROD(--(DROITE(D11:D14;NBCAR(D11:D14)-CHERCHE(" ";D11:D14;1))))
remplacer

Je ne peux pas rajouter du texte dans les colonnes , le fichier serait trop lourd pour l'instant j'essaye avec cette formule :

SOMME(STXT(N402&":"&"N"&402+NB.SI(N403:N415;"*");CHERCHE(" ";N402&":"&"N"&402+NB.SI(N402:N415;"*")-1;1)+1;5)*1)

J'ai décomposé la formule et c'est la fonction somme qui ne marche pas

Pour ne pas voir "texte 0" : une simple MFC

texte somme

Salut mbbp,

Peux-tu envoyer le fichier je ne sais pas comment tu as fais

Merci you are best

Utilisation de la formule déjà proposée dans mon précédent post.

Pour D8 :

=SOMMEPROD(--(DROITE(D5:D7;NBCAR(D5:D7)-CHERCHE(" ";D5:D7;1))))

et MFC :

=$D1="texte 0"

S'applique à : =$D:$D

je viens d'essayer sa ne marche toujours pas, erreur de valeur

merci pour ton aide

Rechercher des sujets similaires à "somme chiffre melanger texte"