SOMMEPROD Vs SOMME.SI.ENS

Bonjour,

Je cherche à utiliser SOMME.SI.ENS dans une matrice, et non plus pour sommer une ligne ou une colonne selon des critères.

J' arrive bien avec SOMMEPROD mais je me demandais s'il était possible d'utiliser SOMME.SI.ENS de la même manière.

Il n'y a donc rien d'urgent mais c'est pour ma culture.

Pouvez vous corriger ma formule si cela vient de là ?

Voir le petit exemple attaché.

Merci d'avance,

Alci

95exemple.xlsx (10.75 Ko)

Bonjour,

en J18 :

=SOMMEPROD(($A$4:$A$14=J$17)*($C$3:$G$3=$I18);$C$4:$G$14)

@ tirer vers le bas et vers la droite

@ + +

Bonjour,

Avec SOMME.SI.ENS, les plages somme et plage critères doivent avoir la même dimension sauf cas particulier à condition d'utiliser la fonction dans une formule matricielle, ce qui enlève tout l’intérêt d'utiliser cette fonction.

Mais tu peut utiliser DECALER et EQUIV pour définir la plage à sommer, comme ceci :

=SOMME.SI.ENS(DECALER($B$4:$B$14;0;EQUIV($I18;$C$3:$G$3;0));$A$4:$A$14;J$17)

ou puisqu'il n'y a plus qu'un seul critère SOMME.SI

=SOMME.SI($A$4:$A$14;J$17;DECALER($B$4:$B$14;0;EQUIV($I18;$C$3:$G$3;0)))

A+

Ok Merci d'avoir regardé.

Il me semblait bien que cela alourdissait la fonction mais je doutais.

MERCI !

Rechercher des sujets similaires à "sommeprod somme ens"