reconnaitre des tranches horaire

Y compris Power BI, Power Query et toute autre question en lien avec Excel
M
MaxwellCosta
Membre habitué
Membre habitué
Messages : 144
Inscrit le : 6 septembre 2015
Version d'Excel : 2010

Message par MaxwellCosta » 2 avril 2016, 09:03

Bonjour à tous,

Je veux écrire une formule en L2 concernant des donnée qui sont en K2

Je m'explique:

En K2 j'ai des données avec un format du type 00:00:35 ( qui sont en fait des horaires)

je veux écrire en L2

Si en K2 la donnée commence par "00:" alors afficher en L2 la valeur "00h-01h" et si en k2 la donnée commence par "01:" alors afficher en L2 la valeur "01h-02h" ainsi de suite jusqu'aux K2 qui commencerai par "23:" pour afficher en L2 la valeur 23h-24h

J'ai commencé cette formule =SI(SOMMEPROD(N(K2={"00:"}))>0;00h-01h;"") mais je ne sais pas faire la suite ou si il existe quelque chose de plus simple pour afficher les tranche horaire.

Merci beaucoup à tous ceux qui pourront m'aider
Max
Avatar du membre
Dan42153
Membre dévoué
Membre dévoué
Messages : 999
Appréciation reçue : 1
Inscrit le : 1 juin 2015
Version d'Excel : 2010 FR

Message par Dan42153 » 2 avril 2016, 09:27

:joindre:
...savoir ce qu'on ne veut pas n'est pas toujours suffisant pour avoir ce qu'on veut...
Avatar du membre
OOoiste
Membre impliqué
Membre impliqué
Messages : 1'572
Appréciations reçues : 14
Inscrit le : 1 octobre 2009
Version d'Excel : office 365

Message par OOoiste » 2 avril 2016, 10:13

Bonjour,
=SI(K2="";"";TEXTE(HEURE(K2);"00")&"h-"&TEXTE(HEURE(K2)+1;"00")&"h")
A+
M
MaxwellCosta
Membre habitué
Membre habitué
Messages : 144
Inscrit le : 6 septembre 2015
Version d'Excel : 2010

Message par MaxwellCosta » 2 avril 2016, 10:51

Merci beaucoup pour votre aide
:btres:
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message