formule pour récupérer toutes les données avec 1 valeur Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
k
kimagure
Membre habitué
Membre habitué
Messages : 50
Inscrit le : 13 mai 2014
Version d'Excel : 2007 fr

Message par kimagure » 23 novembre 2015, 22:13

Bonjour,
Voici ma petite demande.
Je souhaiterais récupérer toutes les « lignes » correspondantes aux « données », c'est-à-dire que je souhaite récupérer dans la colonne G, toutes les « lignes » de A, puis dans I toutes les lignes de B…etc.
Il y a des centaines de « données » et elles peuvent toutes avoir des formes différentes, par contre, les « lignes » sont toujours comme cela.
La valeur MAX est tout en haut, puis se chiffre se décrémente à chaque ligne.
Toutes les données A se suivent, puis toutes les données b se suivent… etc.
Je souhaiterais uniquement avec une formule, pas de formule matricielle ou de macro.
S’il n’y a pas le choix, alors je sais changer d’avis !
;-)
Merci d’avance.
kim.xlsx
(12.04 Kio) Téléchargé 29 fois
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'173
Appréciations reçues : 630
Inscrit le : 27 août 2012
Version d'Excel : 365 Personnel

Message par Jean-Eric » 24 novembre 2015, 01:15

Bonjour,
Une proposition à la six-quatre-deux, si j'ai bien compris. :oops:
En attendant qu'un bulbe rachidien n'intervienne. ;;)
Cdlt.
kim.xlsx
(31.76 Kio) Téléchargé 17 fois
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
Avatar du membre
Wilder3
Membre habitué
Membre habitué
Messages : 146
Inscrit le : 14 novembre 2015
Version d'Excel : 2007fr

Message par Wilder3 » 24 novembre 2015, 07:59

Bonjour. une alternative avec formule

Fonctionnant également

Première ligne =DECALER(A1;EQUIV($F$1;données;0)-1;1)
Deuxième ligne =SIERREUR(SI(DECALER($A$1;(EQUIV(G2;ligne;0)+1);)=$F$1;INDEX(ligne;EQUIV(G2;ligne;0)+1);"");"")
kim.xlsx
(28.09 Kio) Téléchargé 34 fois
k
kimagure
Membre habitué
Membre habitué
Messages : 50
Inscrit le : 13 mai 2014
Version d'Excel : 2007 fr

Message par kimagure » 24 novembre 2015, 16:50

Bonjour,
je me suis servi de la proposition de Wilder, et ça marche super, merci.
8)
ptite autre question.
comment faire, à partir d'une donnée pour récupérer l'information en ligna 1,
par exemple, comment je peux récupérer l'information "ligne" avec 862 ou 861?
merci d'avance.
Avatar du membre
Wilder3
Membre habitué
Membre habitué
Messages : 146
Inscrit le : 14 novembre 2015
Version d'Excel : 2007fr

Message par Wilder3 » 24 novembre 2015, 16:58

Probablement avec la fonction equiv() mais je ne comprends pas trop la question donc sous reserve
k
kimagure
Membre habitué
Membre habitué
Messages : 50
Inscrit le : 13 mai 2014
Version d'Excel : 2007 fr

Message par kimagure » 24 novembre 2015, 17:53

c'est bon, réussi et oui, avec tout simplement un equiv...
merci à toi!
;-)
Avatar du membre
Wilder3
Membre habitué
Membre habitué
Messages : 146
Inscrit le : 14 novembre 2015
Version d'Excel : 2007fr

Message par Wilder3 » 24 novembre 2015, 18:21

Ok
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message